aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/founts/Makefile34
-rw-r--r--graphics/founts/distinfo2
2 files changed, 21 insertions, 15 deletions
diff --git a/graphics/founts/Makefile b/graphics/founts/Makefile
index 85d49869969e..dace223d7018 100644
--- a/graphics/founts/Makefile
+++ b/graphics/founts/Makefile
@@ -1,27 +1,34 @@
-# New Ports collection makefile for: founts
-# Date created: 2012-05-01
-# Whom: nemysis@gmx.ch
-#
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
-#
PORTNAME= founts
PORTVERSION= 12
+PORTREVISION= 1
CATEGORIES= graphics games
-MASTER_SITES= http://www.linuxmotors.com/founts/downloads/
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.linuxmotors.com/founts/downloads/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}.tgz \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}.tgz
MAINTAINER= nemysis@gmx.ch
-COMMENT= A demo/program inspired by Erics cascade
+COMMENT= Demo/program inspired by Erics cascade
LICENSE= GPLv2
USE_SDL= sdl
+CFLAGS= -Wno-return-type
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
PORTDOCS= Changelog README
+OPTIONS_DEFINE= DOCS
+
+DESKTOP_ENTRIES="Founts" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Graphics;Game;" false
+
.include <bsd.port.options.mk>
do-build:
@@ -29,15 +36,12 @@ do-build:
-lm `${SDL_CONFIG} --cflags --libs` founts.c
do-install:
-# Executable
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
-# Documentation
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/founts/distinfo b/graphics/founts/distinfo
index c6a59688bef5..c856fc4cc7e6 100644
--- a/graphics/founts/distinfo
+++ b/graphics/founts/distinfo
@@ -1,2 +1,4 @@
SHA256 (founts-12.tgz) = 46da7a97eef91c162c946914dc81ab523963b4a5faebdf2bfd8482f32a485a8a
SIZE (founts-12.tgz) = 21447
+SHA256 (founts.png) = a8e1dd4ddd78fef3b60e858d4fdc38cdb1388c999031f9306849a09ae0a977d6
+SIZE (founts.png) = 6266