aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/evas-loader-generic/Makefile2
-rw-r--r--graphics/evas_generic_loaders-svg/Makefile34
-rw-r--r--graphics/evas_generic_loaders-svg/distinfo2
-rw-r--r--graphics/evas_generic_loaders-svg/pkg-descr9
-rw-r--r--graphics/evas_generic_loaders-svg/pkg-plist3
6 files changed, 50 insertions, 1 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 003cb8d6e8a9..c6258821189c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -182,6 +182,7 @@
SUBDIR += evas_generic_loaders-pdf
SUBDIR += evas_generic_loaders-ps
SUBDIR += evas_generic_loaders-raw
+ SUBDIR += evas_generic_loaders-svg
SUBDIR += evas_generic_loaders-xcf
SUBDIR += evince
SUBDIR += evolvotron
diff --git a/graphics/evas-loader-generic/Makefile b/graphics/evas-loader-generic/Makefile
index 480f2f125693..a40dbe0b8fa0 100644
--- a/graphics/evas-loader-generic/Makefile
+++ b/graphics/evas-loader-generic/Makefile
@@ -14,7 +14,7 @@ COMMENT= A hardware accelerated canvas API (generic loader)
LICENSE= BSD
-EVAS_GENERIC_LOADERS= gst pdf ps raw xcf
+EVAS_GENERIC_LOADERS= gst pdf ps raw svg xcf
.for NODE in ${EVAS_GENERIC_LOADERS}
OPTIONS+= ${NODE:U} "Install ${NODE} evas generic loader" on
diff --git a/graphics/evas_generic_loaders-svg/Makefile b/graphics/evas_generic_loaders-svg/Makefile
new file mode 100644
index 000000000000..b12c5e87a847
--- /dev/null
+++ b/graphics/evas_generic_loaders-svg/Makefile
@@ -0,0 +1,34 @@
+# Created by: Grzegorz Blach <gblach@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= svg
+PORTVERSION= 1.7.4
+CATEGORIES= graphics enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ LOCAL/gblach/e17/
+PKGNAMEPREFIX= evas_generic_loaders-
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
+
+MAINTAINER= gblach@FreeBSD.org
+COMMENT= Additional loader for Evas (svg)
+
+LICENSE= GPLv2
+
+#LIB_DEPENDS= poppler:${PORTSDIR}/graphics/poppler
+
+DIST_SUBDIR= e17
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= eina
+USE_GNOME= librsvg2 gnomehack pkgconfig
+USE_LDCONFIG= yes
+
+BINSRC= ${WRKSRC}/src/bin/${PORTNAME}
+
+do-build:
+ ${MAKE} -C ${BINSRC}
+
+do-install:
+ ${MAKE} -C ${BINSRC} install
+
+.include <bsd.port.mk>
diff --git a/graphics/evas_generic_loaders-svg/distinfo b/graphics/evas_generic_loaders-svg/distinfo
new file mode 100644
index 000000000000..ad795f8fdb40
--- /dev/null
+++ b/graphics/evas_generic_loaders-svg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/evas_generic_loaders-1.7.4.tar.bz2) = 85779f33e8ad483a9b849a74be8ca3aae22127138a325bae0f079133b2fe4e7c
+SIZE (e17/evas_generic_loaders-1.7.4.tar.bz2) = 200620
diff --git a/graphics/evas_generic_loaders-svg/pkg-descr b/graphics/evas_generic_loaders-svg/pkg-descr
new file mode 100644
index 000000000000..80b633c68130
--- /dev/null
+++ b/graphics/evas_generic_loaders-svg/pkg-descr
@@ -0,0 +1,9 @@
+These are additional "generic" loaders for Evas that are stand-alone
+executables that evas may run from its generic loader module. This
+means that if they crash, the application loading the image does not
+crash also. In addition the licensing of these binaries will not
+affect the license of any application that uses Evas as this uses a
+completely generic execution system that allows anything to be plugged
+in as a loader.
+
+WWW: http://trac.enlightenment.org/e/wiki/Evas_Generic_Loaders
diff --git a/graphics/evas_generic_loaders-svg/pkg-plist b/graphics/evas_generic_loaders-svg/pkg-plist
new file mode 100644
index 000000000000..a59627baf881
--- /dev/null
+++ b/graphics/evas_generic_loaders-svg/pkg-plist
@@ -0,0 +1,3 @@
+lib/evas/utils/evas_image_loader.svg
+@dirrmtry lib/evas/utils
+@dirrmtry lib/evas