aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fractorama/Makefile12
-rw-r--r--graphics/metacam/Makefile12
2 files changed, 12 insertions, 12 deletions
diff --git a/graphics/fractorama/Makefile b/graphics/fractorama/Makefile
index 32aee242571a..8acef739d9fc 100644
--- a/graphics/fractorama/Makefile
+++ b/graphics/fractorama/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fractorama
-# Date created: Apr 15, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= fractorama
PORTVERSION= 1.6.7
@@ -32,6 +28,10 @@ ALL_TARGET= release
CXXFLAGS+= -I${LOCALBASE}/include
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-extract:
.for e in cpp h
@${CP} ${WRKSRC}/lib/tiff/TiffWriter.${e} ${WRKSRC}
@@ -56,7 +56,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../fractorama.exe ${PREFIX}/bin/fractorama
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/../doc && ${FIND} . | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
diff --git a/graphics/metacam/Makefile b/graphics/metacam/Makefile
index 9753c97bb925..2dd378cea1b3 100644
--- a/graphics/metacam/Makefile
+++ b/graphics/metacam/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: metacam
-# Date created: 2 Sep 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= metacam
PORTVERSION= 1.2
@@ -25,11 +21,15 @@ MAN1= metacam.1
ALL_TARGET= ${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}