aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-webcolors/Makefile29
-rw-r--r--graphics/py-webcolors/distinfo2
-rw-r--r--graphics/py-webcolors/pkg-descr19
-rw-r--r--graphics/py-webcolors/pkg-plist3
5 files changed, 54 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index fbb0f9c1e5f2..96bb1f50f615 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -793,6 +793,7 @@
SUBDIR += py-sorl-thumbnail
SUBDIR += py-soya3d
SUBDIR += py-visual
+ SUBDIR += py-webcolors
SUBDIR += pygts
SUBDIR += pymorph
SUBDIR += pyro
diff --git a/graphics/py-webcolors/Makefile b/graphics/py-webcolors/Makefile
new file mode 100644
index 000000000000..cf6176030132
--- /dev/null
+++ b/graphics/py-webcolors/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-webcolors
+# Date created: 2011-08-02
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webcolors
+PORTVERSION= 1.3.1
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Library working with the sRGB color space as used in the HTML and CSS
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
+PORTDOCS= README
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/py-webcolors/distinfo b/graphics/py-webcolors/distinfo
new file mode 100644
index 000000000000..3d59d2ba8a51
--- /dev/null
+++ b/graphics/py-webcolors/distinfo
@@ -0,0 +1,2 @@
+SHA256 (webcolors-1.3.1.tar.gz) = 17691c51d1b2c08d238c432bd39fc4d78de543bb369ddff87c4b46ed07f07427
+SIZE (webcolors-1.3.1.tar.gz) = 6429
diff --git a/graphics/py-webcolors/pkg-descr b/graphics/py-webcolors/pkg-descr
new file mode 100644
index 000000000000..6c05fb6f7ae8
--- /dev/null
+++ b/graphics/py-webcolors/pkg-descr
@@ -0,0 +1,19 @@
+This module provides utility functions for working with the color names
+and color value formats defined by the HTML and CSS specifications for
+use in documents on the Web.
+
+Support is included for the following formats (RGB colorspace only;
+conversion to/from HSL can be handled by the ``colorsys`` module in
+the Python standard library):
+
+* Specification-defined color names
+
+* Six-digit hexadecimal
+
+* Three-digit hexadecimal
+
+* Integer rgb() triplet
+
+* Percentage rgb() triplet
+
+WWW: https://bitbucket.org/ubernostrum/webcolors/overview/
diff --git a/graphics/py-webcolors/pkg-plist b/graphics/py-webcolors/pkg-plist
new file mode 100644
index 000000000000..db314e9bb47b
--- /dev/null
+++ b/graphics/py-webcolors/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/webcolors.py
+%%PYTHON_SITELIBDIR%%/webcolors.pyc
+%%PYTHON_SITELIBDIR%%/webcolors.pyo