aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gd/Makefile2
-rw-r--r--graphics/ruby-gd/Makefile3
2 files changed, 2 insertions, 3 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index 24f89dd37ef2..16c635d6a382 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -42,7 +42,7 @@ OPTIONS= X11 "X11 support" off \
.if !defined(WITHOUT_X11)
.if defined(WITH_XPM)
-USE_XPM= yes
+USE_XORG= xpm x11
CPPFLAGS+= -I${X11BASE}/include/X11 -I${X11BASE}/include -DHAVE_LIBXPM
LDFLAGS+= -L${X11BASE}/lib -lXpm -lX11
LDFLAGS2+= -L${X11BASE}/lib
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index 4bb8a78eb10d..682cab9434b4 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -44,8 +44,7 @@ WITH_X11_CHECK= # empty
.endif
.if !empty(WITH_X11_CHECK)
-USE_XLIB= yes
-USE_XPM= yes
+USE_XORG= xpm x11
PKGNAMESUFFIX_XPM= +xpm
CONFIGURE_ARGS+= --with-X11-dir="${X11BASE}" --with-xpm
.endif