aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/bugle/Makefile4
-rw-r--r--graphics/gscan2pdf/Makefile1
-rw-r--r--graphics/p5-Acme-Steganography-Image-Png/Makefile8
-rw-r--r--graphics/p5-CAD-Drawing-Template/Makefile8
-rw-r--r--graphics/p5-CAD-Drawing/Makefile8
-rw-r--r--graphics/p5-GD-Graph/Makefile10
-rw-r--r--graphics/p5-GD-SVG/Makefile10
-rw-r--r--graphics/p5-GD/Makefile8
-rw-r--r--graphics/p5-Graph-Easy/Makefile10
-rw-r--r--graphics/p5-Graph-SocialMap/Makefile10
-rw-r--r--graphics/p5-Graph-Writer-GraphViz/Makefile10
-rw-r--r--graphics/p5-GraphViz-Traverse/Makefile8
-rw-r--r--graphics/p5-Image-Caa/Makefile8
-rw-r--r--graphics/p5-Image-Info/Makefile8
-rw-r--r--graphics/p5-Image-MetaData-GQview/Makefile10
-rw-r--r--graphics/p5-Image-MetaData-JPEG/Makefile8
-rw-r--r--graphics/p5-Image-Size/Makefile8
-rw-r--r--graphics/p5-Imager/Makefile10
-rw-r--r--graphics/p5-SVG-DOM2/Makefile8
-rw-r--r--graphics/p5-SVG-Graph/Makefile8
-rw-r--r--graphics/p5-SVG-Metadata/Makefile8
-rw-r--r--graphics/p5-SWF-Builder/Makefile10
-rw-r--r--graphics/p5-SWF-File/Makefile8
-rw-r--r--graphics/p5-Tk-JPEG-Lite/Makefile10
-rw-r--r--graphics/p5-Visio/Makefile10
-rw-r--r--graphics/p5-ming/Makefile1
26 files changed, 32 insertions, 178 deletions
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
index 406f0cb8068c..493e053cc5d6 100644
--- a/graphics/bugle/Makefile
+++ b/graphics/bugle/Makefile
@@ -46,10 +46,6 @@ OPTIONS+= THREADS "Use pthreads" off
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.x or later to build. Install lang/perl5.8 then try again
-.endif
-
.if defined(WITH_AVCODEC)
CONFIGURE_ARGS+=--with-lavc
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
diff --git a/graphics/gscan2pdf/Makefile b/graphics/gscan2pdf/Makefile
index 10aa59325c44..f8e57401203b 100644
--- a/graphics/gscan2pdf/Makefile
+++ b/graphics/gscan2pdf/Makefile
@@ -30,7 +30,6 @@ RUN_DEPENDS= p5-PDF-API2>=0.57:${PORTSDIR}/textproc/p5-PDF-API2 \
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= librsvg2
-USE_PERL5= yes
PERL_CONFIGURE= yes
MAN1= ${PORTNAME}.1
diff --git a/graphics/p5-Acme-Steganography-Image-Png/Makefile b/graphics/p5-Acme-Steganography-Image-Png/Makefile
index 8651aa4fc8f3..5e9f4fe7d8c1 100644
--- a/graphics/p5-Acme-Steganography-Image-Png/Makefile
+++ b/graphics/p5-Acme-Steganography-Image-Png/Makefile
@@ -24,10 +24,4 @@ PERL_CONFIGURE= yes
MAN3= Acme::Steganography::Image::Png.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-CAD-Drawing-Template/Makefile b/graphics/p5-CAD-Drawing-Template/Makefile
index 77d5644a992b..a5cd0624ee64 100644
--- a/graphics/p5-CAD-Drawing-Template/Makefile
+++ b/graphics/p5-CAD-Drawing-Template/Makefile
@@ -24,10 +24,4 @@ MAN3= CAD::Drawing::Template.3
PERL_MODBUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-CAD-Drawing/Makefile b/graphics/p5-CAD-Drawing/Makefile
index 3e4f86b3d160..b98e43e5f036 100644
--- a/graphics/p5-CAD-Drawing/Makefile
+++ b/graphics/p5-CAD-Drawing/Makefile
@@ -41,10 +41,4 @@ MAN3= CAD::Drawing.3 \
PERL_MODBUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-GD-Graph/Makefile b/graphics/p5-GD-Graph/Makefile
index 2704942bb364..ce4a3c808704 100644
--- a/graphics/p5-GD-Graph/Makefile
+++ b/graphics/p5-GD-Graph/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/GD/Text/Align.pm:${PORTSDIR}/graphics/p5-GD-TextUtil
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+PERL_CONFIGURE= 5.8.0+
MAN3= GD::Graph.3 \
GD::Graph::Data.3 \
@@ -33,10 +33,4 @@ MAN3= GD::Graph.3 \
post-patch:
@${FIND} ${WRKSRC} -name "*.orig" -print0 | ${XARGS} -0 ${RM} -f
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-GD-SVG/Makefile b/graphics/p5-GD-SVG/Makefile
index b22a7e2e5c60..a53691bf4089 100644
--- a/graphics/p5-GD-SVG/Makefile
+++ b/graphics/p5-GD-SVG/Makefile
@@ -20,14 +20,8 @@ COMMENT= Seamlessly enable SVG output from scripts written using GD
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/SVG.pm:${PORTSDIR}/textproc/p5-SVG
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+ #inherited from graphics/p5-GD
MAN3= GD::SVG.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800 #inherited from graphics/p5-GD
-IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-GD/Makefile b/graphics/p5-GD/Makefile
index 9d5a9b085192..658a80128394 100644
--- a/graphics/p5-GD/Makefile
+++ b/graphics/p5-GD/Makefile
@@ -28,10 +28,4 @@ MAN1= bdf2gdfont.pl.1
MAN3= GD.3 GD::Polyline.3 GD::Simple.3 \
GD::Image.3 GD::Polygon.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Graph-Easy/Makefile b/graphics/p5-Graph-Easy/Makefile
index e9e0a1f530e2..341ce34a8528 100644
--- a/graphics/p5-Graph-Easy/Makefile
+++ b/graphics/p5-Graph-Easy/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scal
${SITE_PERL}/Heap.pm:${PORTSDIR}/devel/p5-Heap
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
MAN1= graph-easy.1
@@ -49,10 +49,4 @@ MAN3= Graph::Easy.3 \
Graph::Easy::Parser::Graphviz.3 \
Graph::Easy::Parser::VCG.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Graph-SocialMap/Makefile b/graphics/p5-Graph-SocialMap/Makefile
index 2733e4d41ed5..29d643d3fdb0 100644
--- a/graphics/p5-Graph-SocialMap/Makefile
+++ b/graphics/p5-Graph-SocialMap/Makefile
@@ -25,12 +25,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
MAN3= Graph::SocialMap.3
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= currently requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Graph-Writer-GraphViz/Makefile b/graphics/p5-Graph-Writer-GraphViz/Makefile
index f014e9e2dad1..80d99395577a 100644
--- a/graphics/p5-Graph-Writer-GraphViz/Makefile
+++ b/graphics/p5-Graph-Writer-GraphViz/Makefile
@@ -24,12 +24,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
MAN3= Graph::Writer::GraphViz.3
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires at least Perl 5.8.0+. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-GraphViz-Traverse/Makefile b/graphics/p5-GraphViz-Traverse/Makefile
index 6b9018385d76..9d3c48105e10 100644
--- a/graphics/p5-GraphViz-Traverse/Makefile
+++ b/graphics/p5-GraphViz-Traverse/Makefile
@@ -23,10 +23,4 @@ MAN3= GraphViz::Traverse.3 GraphViz::Traverse::Filesystem.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Caa/Makefile b/graphics/p5-Image-Caa/Makefile
index 3eb1c868941b..dacfe5786982 100644
--- a/graphics/p5-Image-Caa/Makefile
+++ b/graphics/p5-Image-Caa/Makefile
@@ -26,10 +26,4 @@ post-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/demos/* ${EXAMPLESDIR}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Info/Makefile b/graphics/p5-Image-Info/Makefile
index c6fde4f0b06d..90211501d78a 100644
--- a/graphics/p5-Image-Info/Makefile
+++ b/graphics/p5-Image-Info/Makefile
@@ -26,10 +26,4 @@ MAN3= Image::Info.3 Image::Info::BMP.3 Image::Info::SVG.3 \
Image::Info::TIFF.3 Image::Info::PPM.3 \
Image::Info::XBM.3 Image::Info::XPM.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500602
-BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-MetaData-GQview/Makefile b/graphics/p5-Image-MetaData-GQview/Makefile
index 0da8f2890d4c..1f378d66fd5c 100644
--- a/graphics/p5-Image-MetaData-GQview/Makefile
+++ b/graphics/p5-Image-MetaData-GQview/Makefile
@@ -19,12 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Image::MetaData::GQview.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-post-patch:
- ${PERL} -pi -e 's,^use warnings;.*,,g' ${WRKSRC}/Makefile.PL \
- ${WRKSRC}/lib/Image/MetaData/GQview.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-MetaData-JPEG/Makefile b/graphics/p5-Image-MetaData-JPEG/Makefile
index 3a8dcb9f8a6d..7e9c576a328e 100644
--- a/graphics/p5-Image-MetaData-JPEG/Makefile
+++ b/graphics/p5-Image-MetaData-JPEG/Makefile
@@ -22,10 +22,4 @@ MAN3= Image::MetaData::JPEG.3 \
Image::MetaData::JPEG::Structures.3 \
Image::MetaData::JPEG::TagLists.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Size/Makefile b/graphics/p5-Image-Size/Makefile
index 835cd2440e2a..5b7d71437b2e 100644
--- a/graphics/p5-Image-Size/Makefile
+++ b/graphics/p5-Image-Size/Makefile
@@ -23,10 +23,4 @@ PERL_MODBUILD= yes
MAN1= imgsize.1
MAN3= Image::Size.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Imager/Makefile b/graphics/p5-Imager/Makefile
index 0a98db499800..8a3ac4cf4972 100644
--- a/graphics/p5-Imager/Makefile
+++ b/graphics/p5-Imager/Makefile
@@ -24,17 +24,11 @@ LIB_DEPENDS= \
ungif:${PORTSDIR}/graphics/libungif
USE_FREETYPE= yes
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
CONFIGURE_ENV= IM_LIBPATH="${LOCALBASE}/lib" \
IM_CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
IM_INCPATH="${LOCALBASE}/include/freetype1/freetype"
.include "Makefile.man"
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-SVG-DOM2/Makefile b/graphics/p5-SVG-DOM2/Makefile
index 5e81b0a828e0..c9def834d125 100644
--- a/graphics/p5-SVG-DOM2/Makefile
+++ b/graphics/p5-SVG-DOM2/Makefile
@@ -23,10 +23,4 @@ MAN3= SVG::DOM2.3 SVG::DOM2::Attribute::Transform.3 \
SVG::DOM2::Element::Shape::Font.3 \
SVG::DOM2::Element::Shape::Stroke.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-SVG-Graph/Makefile b/graphics/p5-SVG-Graph/Makefile
index b84c7713f3d2..fbd3ef35a374 100644
--- a/graphics/p5-SVG-Graph/Makefile
+++ b/graphics/p5-SVG-Graph/Makefile
@@ -26,10 +26,4 @@ PERL_CONFIGURE= yes
MAN3= SVG::Graph.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-SVG-Metadata/Makefile b/graphics/p5-SVG-Metadata/Makefile
index a29b60247e6d..68ea43d580dc 100644
--- a/graphics/p5-SVG-Metadata/Makefile
+++ b/graphics/p5-SVG-Metadata/Makefile
@@ -26,10 +26,4 @@ MAN3= SVG::Metadata.3
post-patch:
${RM} -f ${WRKSRC}/lib/SVG/Metadata.pm.orig
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= This port requires perl 5.6.0 or later, Install lang/perl5 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-SWF-Builder/Makefile b/graphics/p5-SWF-Builder/Makefile
index 9f3cd4fdab8d..b23fb2368504 100644
--- a/graphics/p5-SWF-Builder/Makefile
+++ b/graphics/p5-SWF-Builder/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${SITE_PERL}/SWF/Element.pm:${PORTSDIR}/graphics/p5-SWF-File \
${SITE_PERL}/Font/TTF/Font.pm:${PORTSDIR}/x11-fonts/p5-Font-TTF
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
MAN3= SWF::Builder.3 SWF::Builder::ActionScript.3 \
SWF::Builder::Character::Bitmap.3 \
@@ -39,10 +39,4 @@ post-patch:
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-SWF-File/Makefile b/graphics/p5-SWF-File/Makefile
index 534c200e1be7..25ecf0e3f9de 100644
--- a/graphics/p5-SWF-File/Makefile
+++ b/graphics/p5-SWF-File/Makefile
@@ -33,10 +33,4 @@ post-patch:
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 or lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Tk-JPEG-Lite/Makefile b/graphics/p5-Tk-JPEG-Lite/Makefile
index d07338c63cf0..226ef1ed415d 100644
--- a/graphics/p5-Tk-JPEG-Lite/Makefile
+++ b/graphics/p5-Tk-JPEG-Lite/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
MAN1= tkjpeg-lite.1
MAN3= Tk::JPEG::Lite.3
@@ -31,10 +31,4 @@ post-patch:
${WRKSRC}/Makefile.PL ${WRKSRC}/MANIFEST
@${MV} ${WRKSRC}/tkjpeg ${WRKSRC}/tkjpeg-lite
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= needs Perl 5.8.0 or greater, please upgrade your Perl
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-Visio/Makefile b/graphics/p5-Visio/Makefile
index 6a30e2c6016e..17fd2e63647c 100644
--- a/graphics/p5-Visio/Makefile
+++ b/graphics/p5-Visio/Makefile
@@ -19,16 +19,10 @@ BUILD_DEPENDS= p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.1+
MAN3= Visio.3 Visio::Hyperlink.3 Visio::Layout.3 Visio::Line.3 \
Visio::Master.3 Visio::Page.3 Visio::PageProps.3 \
Visio::PageSheet.3 Visio::Shape.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500801
-IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-ming/Makefile b/graphics/p5-ming/Makefile
index 1d79880ad737..c4dc5d9a4510 100644
--- a/graphics/p5-ming/Makefile
+++ b/graphics/p5-ming/Makefile
@@ -21,7 +21,6 @@ LIB_DEPENDS= ming.4:${PORTSDIR}/graphics/ming
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/perl_ext
-USE_PERL5= yes
PERL_CONFIGURE= yes
CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"