aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aoi/Makefile33
1 files changed, 12 insertions, 21 deletions
diff --git a/graphics/aoi/Makefile b/graphics/aoi/Makefile
index a5c21b84dd26..b24d04980db7 100644
--- a/graphics/aoi/Makefile
+++ b/graphics/aoi/Makefile
@@ -14,11 +14,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Open source Java written 3D modelling and rendering studio
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libjogl.so:graphics/jogl
-USES= dos2unix zip
-DOS2UNIX_FILES= ../AoI_Manual/*.html
+USES= zip
+DOS2UNIX_FILES= ../AoI_Manual/*.html # USES=dos2unix is optional
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
@@ -28,29 +29,20 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
PORTDOCS= *
-DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= HISTORY README
-
-DOCSRCDIR2= ${WRKDIR}/AoI_Manual
-DOCSDIR2= ${DOCSDIR}/AoI_Manual
-DOC_FILES2= *
-
-OPTIONS_DEFINE= DOCS
-
SUB_FILES= ${PORTNAME} pkg-deinstall pkg-message
DESKTOP_ENTRIES="Art of Illusion" "3D modelling and rendering studio" \
"${PORTNAME}" "${PORTNAME}" "Graphics;3DGraphics;" ""
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
+
+DOCS_DISTFILES= manual${PORTVERSION}${EXTRACT_SUFX}:docs
+DOCS_USES= dos2unix
-.if ${PORT_OPTIONS:MDOCS}
-DISTFILES+= manual${PORTVERSION}${EXTRACT_SUFX}:docs
-post-extract:
+post-extract-DOCS-on:
@(cd ${WRKDIR} && ${MV} "AoI Manual" AoI_Manual)
-.endif
-post-patch::
+post-patch:
@(cd ${WRKSRC} && ${RM} "Textures and Materials/Library/.DS_Store")
do-install:
@@ -65,10 +57,9 @@ do-install:
${LN} -sf ${DATADIR}/Icons/48x48.png \
${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
-.if ${PORT_OPTIONS:MDOCS}
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
- @(cd ${WRKDIR}/AoI_Manual && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR2})
-.endif
+ cd ${WRKSRC} && ${INSTALL_DATA} HISTORY README ${STAGEDIR}${DOCSDIR}
+ cd ${WRKDIR} && ${COPYTREE_SHARE} "AoI_Manual" ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>