aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-pillow/Makefile12
-rw-r--r--graphics/py-pillow/distinfo6
2 files changed, 9 insertions, 9 deletions
diff --git a/graphics/py-pillow/Makefile b/graphics/py-pillow/Makefile
index 13024ca0290a..15a68ead5b8f 100644
--- a/graphics/py-pillow/Makefile
+++ b/graphics/py-pillow/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pillow
-PORTVERSION= 3.4.2
-PORTREVISION= 1
+PORTVERSION= 5.0.0
CATEGORIES= graphics python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,6 +14,9 @@ LICENSE_NAME= Standard PIL License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${FLAVOR}
+
OPTIONS_DEFINE= FREETYPE JPEG JPEG2000 LCMS PNG TIFF TKINTER WEBP
OPTIONS_DEFAULT= FREETYPE JPEG JPEG2000 PNG TKINTER WEBP
@@ -53,6 +55,7 @@ WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
WEBP_VARS= PYDISTUTILS_BUILDARGS+="--enable-webp --enable-webpmux"
WEBP_VARS_OFF= PYDISTUTILS_BUILDARGS+="--disable-webp --disable-webpmux"
+# Python 2.7,3.4+
USES= cpe python
USE_GITHUB= yes
USE_PYTHON= autoplist concurrent distutils
@@ -71,9 +74,6 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PIL/*.so
do-test:
- @cd ${WRKSRC} && \
- ${PYTHON_CMD} ${PYSETUP} build_ext -i && \
- ${PYTHON_CMD} selftest.py && \
- ${PYTHON_CMD} -m nose -vx Tests/test_*.py
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.post.mk>
diff --git a/graphics/py-pillow/distinfo b/graphics/py-pillow/distinfo
index 059e5dc34ae6..f3b8f436e956 100644
--- a/graphics/py-pillow/distinfo
+++ b/graphics/py-pillow/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1482579087
-SHA256 (python-pillow-Pillow-3.4.2_GH0.tar.gz) = 0ee762ab924e004b7e69643b44e82cf65e0fa1f16862e11bd821950dbbc5f3d3
-SIZE (python-pillow-Pillow-3.4.2_GH0.tar.gz) = 10746584
+TIMESTAMP = 1521173377
+SHA256 (python-pillow-Pillow-5.0.0_GH0.tar.gz) = e85301adaa827b9f29ab518eff99d5719e572ca5f369866ebfe57a92e7135aec
+SIZE (python-pillow-Pillow-5.0.0_GH0.tar.gz) = 14155901