aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile3
-rw-r--r--graphics/ImageMagick/distinfo4
-rw-r--r--graphics/ImageMagick/files/patch-configure22
-rw-r--r--graphics/ImageMagick/files/patch-magick-string.c13
4 files changed, 3 insertions, 39 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 3525961a2126..6a6e699a079b 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ImageMagick
-DISTVERSION= 6.7.3-0
-PORTREVISION= 1
+DISTVERSION= 6.7.3-1
CATEGORIES= graphics perl5
MASTER_SITES= ftp://ftp.imagemagick.org/pub/ImageMagick/ \
http://image_magick.veidrodis.com/image_magick/ \
diff --git a/graphics/ImageMagick/distinfo b/graphics/ImageMagick/distinfo
index 42a8278b3ccc..01454bfc16ac 100644
--- a/graphics/ImageMagick/distinfo
+++ b/graphics/ImageMagick/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ImageMagick-6.7.3-0.tar.xz) = 8159b3c3fa2c121b30a020df5ae87ec345a79608379413a8fa38fe3000d0607b
-SIZE (ImageMagick-6.7.3-0.tar.xz) = 7946508
+SHA256 (ImageMagick-6.7.3-1.tar.xz) = 5edf86aa80af7919a2197c39fd134d348f0699fd684f250ddc918bf8e73e3d4a
+SIZE (ImageMagick-6.7.3-1.tar.xz) = 7949300
diff --git a/graphics/ImageMagick/files/patch-configure b/graphics/ImageMagick/files/patch-configure
deleted file mode 100644
index 29e2b4cd392e..000000000000
--- a/graphics/ImageMagick/files/patch-configure
+++ /dev/null
@@ -1,22 +0,0 @@
---- configure.orig 2011-10-11 16:57:23.403957757 +0200
-+++ configure 2011-10-11 16:58:06.944958010 +0200
-@@ -30070,8 +30070,8 @@
-
- if test $passed -gt 0; then
- for var in 5 4 2 '' ; do
-- if test "$have_png" == 'no' ; then
-- if test "x${var}" == 'x' ; then
-+ if test "$have_png" = 'no' ; then
-+ if test "x${var}" = 'x' ; then
- pnglib='png'
- else
- pnglib="png1${var}"
-@@ -30080,7 +30080,7 @@
- # Test for compatible LIBPNG library
- failed=0
- passed=0
-- if test "$with_png" == 'yes' -o "$with_png" == "libpng1${var}" ; then
-+ if test "$with_png" = 'yes' -o "$with_png" = "libpng1${var}" ; then
- if test "${pnglib}" != 'png' ; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for LIBPNG1${var} support " >&5
- $as_echo_n "checking for LIBPNG1${var} support ... " >&6; }
diff --git a/graphics/ImageMagick/files/patch-magick-string.c b/graphics/ImageMagick/files/patch-magick-string.c
deleted file mode 100644
index 3e07953f046a..000000000000
--- a/graphics/ImageMagick/files/patch-magick-string.c
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: magick/string.c
-===================================================================
---- magick/string.c (revision 5596)
-+++ magick/string.c (revision 5597)
-@@ -734,6 +734,8 @@
- register size_t
- n;
-
-+ if (source == (const char *) NULL)
-+ return(0);
- p=source;
- q=destination;
- for (n=length; n > 4; n-=4)