aboutsummaryrefslogtreecommitdiffstats
path: root/irc/erc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/erc/Makefile')
-rw-r--r--irc/erc/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/irc/erc/Makefile b/irc/erc/Makefile
deleted file mode 100644
index d91cd8bf9571..000000000000
--- a/irc/erc/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# Ports collection makefile for: erc
-# Date created: 23 February 2004
-# Whom: Dryice Liu <dryice@liu.com.cn>
-#
-# $FreeBSD$
-#
-
-PORTNAME= erc
-PORTVERSION= 5.1.2
-PORTREVISION= 2
-CATEGORIES+= irc elisp
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= erc
-PKGNAMESUFFIX= -${EMACS_PORT_NAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= ERC is an Emacs InternetRelayChat client
-
-BROKEN= Conflicting dependencies
-DEPRECATED= Has been broken for more than 6 months
-EXPIRATION_DATE=2008-09-19
-
-USE_EMACS= yes
-
-ERC_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
-
-USE_GMAKE= yes
-
-BUILD_DEPENDS+= \
- ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/cedet/common/cedet.el:${PORTSDIR}/devel/cedet${PORTNAMESUFFIX} \
- ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/bbdb/bbdb.el:${PORTSDIR}/databases/bbdb${PORTNAMESUFFIX} \
- ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/emacs-chess/chess.elc:${PORTSDIR}/games/emacs-chess
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-
-do-install:
- ${MKDIR} ${ERC_LISPDIR}
-.for i in *.el *.elc
- ${INSTALL_DATA} ${WRKSRC}/${i} ${ERC_LISPDIR}
-.endfor
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>