aboutsummaryrefslogtreecommitdiffstats
path: root/irc/inspircd
diff options
context:
space:
mode:
Diffstat (limited to 'irc/inspircd')
-rw-r--r--irc/inspircd/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/irc/inspircd/Makefile b/irc/inspircd/Makefile
index cb6604c8f639..9f8d2e4dabee 100644
--- a/irc/inspircd/Makefile
+++ b/irc/inspircd/Makefile
@@ -31,6 +31,8 @@ INSPIRCD_LOG?= /var/log/${PORTNAME}/ircd.log
SUB_LIST+= PORTNAME=${PORTNAME} \
INSPIRCD_USR=${INSPIRCD_USR} \
INSPIRCD_GRP=${INSPIRCD_GRP} \
+ INSPIRCD_LOG=${INSPIRCD_LOG} \
+ INSPIRCD_RUN=${INSPIRCD_RUN}
PLIST_SUB+= INSPIRCD_GRP=${INSPIRCD_GRP}
SUB_FILES+= pkg-deinstall
@@ -90,7 +92,8 @@ PLIST_SUB+= SQLITE3="@comment "
.endif
.if defined(WITH_GNUTLS) && !defined(WITHOUT_GNUTLS)
-LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls \
+ gcrypt.18:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+= --enable-gnutls
PLIST_SUB+= GNUTLS=""
.else