aboutsummaryrefslogtreecommitdiffstats
path: root/irc/insub/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/insub/Makefile')
-rw-r--r--irc/insub/Makefile39
1 files changed, 16 insertions, 23 deletions
diff --git a/irc/insub/Makefile b/irc/insub/Makefile
index 51b7030b6489..9759ef6ebfff 100644
--- a/irc/insub/Makefile
+++ b/irc/insub/Makefile
@@ -6,43 +6,36 @@
#
PORTNAME= insub
-PORTVERSION= 10.1
-#PORTREVISION= 1
+PORTVERSION= 13.0
CATEGORIES= irc
MASTER_SITES= http://gruntle.org/projects/irssi/insub/
MAINTAINER= adamw@FreeBSD.org
-COMMENT= Some scripts for expressing how you feel on irc and the web
+COMMENT= Some scripts for expressing how you feel on IRC and the web
NO_BUILD= YES
USE_BZIP2= YES
-USE_PERL5= YES
+USE_PERL5= 5.6+
-SCRIPT= ${PORTNAME}.pl
+SCRIPT= ${PORTNAME}.pl
-BUILD_DEPENDS+= cowsay:${PORTSDIR}/games/cowsay
-RUN_DEPENDS+= figlet:${PORTSDIR}/misc/figlet
-RUN_DEPENDS+= ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
-
-.include <bsd.port.pre.mk>
+RUN_DEPENDS= cowsay:${PORTSDIR}/games/cowsay \
+ figlet:${PORTSDIR}/misc/figlet
post-install:
@${ECHO}
- @${ECHO} " insub has been installed in irssi's global script store."
- @${ECHO} " To run, you should type '/script load insub' from within"
- @${ECHO} " the irssi client."
+ @${ECHO} " To use insub in irssi, type '/script load insub'"
+ @${ECHO} " from within the irssi client."
@${ECHO}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${SCRIPT} ${LOCALBASE}/bin/${SCRIPT:R}
- ${MKDIR} ${LOCALBASE}/share/irssi/scripts/
+ ${INSTALL_SCRIPT} ${WRKSRC}/${SCRIPT} ${PREFIX}/bin/${SCRIPT:R}
+ ${MKDIR} ${PREFIX}/share/irssi/scripts/
${INSTALL_DATA} ${WRKSRC}/${SCRIPT} \
- ${LOCALBASE}/share/irssi/scripts/${SCRIPT}
- for i in ${WRKSRC}/cows/* ; do \
- case `basename $$i` in \
- *) ${INSTALL_DATA} $$i ${LOCALBASE}/share/cows; \
- esac \
- done
-
-.include <bsd.port.post.mk>
+ ${PREFIX}/share/irssi/scripts/${SCRIPT}
+ ${MKDIR} ${PREFIX}/share/cows/
+ cd ${WRKSRC} && \
+ ${FIND} cows | ${CPIO} -pdmvu ${PREFIX}/share/
+
+.include <bsd.port.mk>