aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ircd-hybrid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/ircd-hybrid/Makefile')
-rw-r--r--irc/ircd-hybrid/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/irc/ircd-hybrid/Makefile b/irc/ircd-hybrid/Makefile
index c8e380b284ae..dbc301d73812 100644
--- a/irc/ircd-hybrid/Makefile
+++ b/irc/ircd-hybrid/Makefile
@@ -84,6 +84,9 @@ CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/ircd-hybrid \
--ohelpdir=${PREFIX}/share/${PORTNAME}-${PORTVERSION}/help/opers \
--messagedir=${PREFIX}/share/${PORTNAME}-${PORTVERSION}/messages \
+pre-patch:
+ @${SED} -e "s#%%PORTVERSION%%#${PORTVERSION}#" ${FILESDIR}/include-config.h.pre-patch > ${FILESDIR}/patch-include-config.h
+
post-patch:
@${REINPLACE_CMD} -e "s#man8#man/man8#" ${WRKSRC}/doc/Makefile.in
@${MV} ${WRKSRC}/doc/ircd.motd ${WRKSRC}/doc/ircd.motd.sample
@@ -100,4 +103,7 @@ post-install:
@${INSTALL_SCRIPT} ${WRKDIR}/ircd-hybrid.sh ${PREFIX}/etc/rc.d
@${SED} -e "s#/usr/local/#${PREFIX}/#" ${PKGMESSAGE}
+pre-clean:
+ @${RM} -f ${FILESDIR}/patch-include-config.h
+
.include <bsd.port.mk>