aboutsummaryrefslogtreecommitdiffstats
path: root/irc/irssi-xmpp-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/irssi-xmpp-devel/Makefile')
-rw-r--r--irc/irssi-xmpp-devel/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/irc/irssi-xmpp-devel/Makefile b/irc/irssi-xmpp-devel/Makefile
new file mode 100644
index 000000000000..06629f811371
--- /dev/null
+++ b/irc/irssi-xmpp-devel/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: irssi-xmpp
+# Date created: 11 September 2007
+# Whom: Philippe Audeoud <jadawin@tuxaco.net>
+# $FreeBSD$
+
+PORTNAME= irssi-xmpp
+PORTVERSION= 0.13
+CATEGORIES= irc
+MASTER_SITES= http://cybione.org/src/irssi-xmpp/
+
+MAINTAINER= jadawin@tuxaco.net
+COMMENT= Irssi-xmpp is an irssi plugin to connect to the Jabber network
+
+BUILD_DEPENDS= irssi:${PORTSDIR}/irc/irssi
+RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
+LIB_DEPENDS= loudmouth:${PORTSDIR}/net-im/loudmouth
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+MAKE_ENV= IRSSI_INCLUDE="${LOCALBASE}/include/irssi/"
+
+PLIST_FILES= lib/irssi/modules/libfe_xmpp.so \
+ lib/irssi/modules/libxmpp_core.so
+PORTDOCS= README
+
+do-install:
+.for data in core fe-common
+ ${MKDIR} ${PREFIX}/lib/irssi/modules
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${data}/*.so \
+ ${PREFIX}/lib/irssi/modules
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>