aboutsummaryrefslogtreecommitdiffstats
path: root/irc/lostirc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/lostirc/Makefile')
-rw-r--r--irc/lostirc/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/irc/lostirc/Makefile b/irc/lostirc/Makefile
new file mode 100644
index 000000000000..18449d168215
--- /dev/null
+++ b/irc/lostirc/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: irc/lostirc
+# Date created: 01 Jul 2002
+# Whom: Juan Salaverria <rael@vectorstar.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lostirc
+PORTVERSION= 0.1.2
+CATEGORIES= irc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= rael@vectorstar.net
+
+LIB_DEPENDS= gtkmm.2:${PORTSDIR}/x11-toolkits/gtk-- \
+ sigc:${PORTSDIR}/devel/libsigc++
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+GNU_CONFIGURE= yes
+
+MAN1= lostirc.1
+
+DOCS= AUTHORS COPYING ChangeLog TODO README INSTALL
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>