aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ptlink-services
diff options
context:
space:
mode:
Diffstat (limited to 'irc/ptlink-services')
-rw-r--r--irc/ptlink-services/Makefile7
-rw-r--r--irc/ptlink-services/pkg-install28
2 files changed, 6 insertions, 29 deletions
diff --git a/irc/ptlink-services/Makefile b/irc/ptlink-services/Makefile
index d70ebb4cd59d..943902b048e7 100644
--- a/irc/ptlink-services/Makefile
+++ b/irc/ptlink-services/Makefile
@@ -16,11 +16,17 @@ DISTNAME= PTlinkIRC.${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= PTlink IRC services
+DEPRECATED= No upstream source, no distfile and no maintainer
+EXPIRATION_DATE=2011-09-03
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5= yes
USE_MYSQL= yes
+USERS= ircd
+GROUPS= ${USERS}
+
USE_RC_SUBR= ptlink-services.sh
SUB_FILES= pkg-message
@@ -30,7 +36,6 @@ CONFIGURE_ARGS= --sysconfdir=${SYSCONFDIR} --localstatedir=/var \
--with-pidfile=/var/run/ircsvs.pid
post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CHOWN} -R ircd:ircd ${SYSCONFDIR}
@${CAT} ${PKGMESSAGE}
diff --git a/irc/ptlink-services/pkg-install b/irc/ptlink-services/pkg-install
deleted file mode 100644
index d837e4e6e306..000000000000
--- a/irc/ptlink-services/pkg-install
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-case $2 in
-POST-INSTALL)
- USER=ircd
- GROUP=ircd
- UID=72
- GID=72
-
- if pw groupshow "${GROUP}" > /dev/null 2>&1; then
- echo "===> Using existing group ${GROUP}"
- else
- echo "===> Adding group ${GROUP}"
- pw groupadd ${GROUP} -g ${GID} || exit 1
- fi
-
- if pw usershow "${USER}" > /dev/null 2>&1; then
- echo "===> Using existing user ${USER}"
- else
- echo "===> Adding user ${USER}"
- pw adduser ${USER} -u ${UID} -g ${GROUP} -h - -d "/nonexistent" \
- -s "/nonexistent" -c "IRC daemon" || exit 1
- fi
- ;;
-esac
d>2014-10-172-5/+4 * Update the default version of GCC in the Ports Collection from GCC 4.7.4gerald2014-09-112-1/+2 * Remove non staged ports without pending PR from textproc and vietnamesebapt2014-09-0223-923/+0 * Mark BROKEN: Fails to installantoine2014-08-311-0/+2 * Upgrade OpenEXR and ilmbase to 2.2.0.mandree2014-08-161-0/+1 * - Fix build with clang (functions not returing value)pawel2014-08-087-20/+20 * Add staging supportpawel2014-08-071-5/+2 * Add staging supportpawel2014-08-071-5/+2 * Add staging supportpawel2014-08-071-5/+2 * Add staging supportpawel2014-08-071-5/+2 * Remove indefinite articles and trailing periods from COMMENT, plusolgeni2014-08-032-2/+2 * Convert some more USE_BZIP2 to USES=tar:bzip2adamw2014-07-301-1/+1 * Rename vietnamese/ patch-xy patches to reflect the files they modify.adamw2014-07-296-0/+0 * vietnamese/libviet: Fix last commitmarino2014-07-291-1/+1 * vietnamese/libviet: respect CC/CFLAGSmarino2014-07-281-0/+2 * vietnamese/vnroff: integrate pkg-plist and cleanup makefilemarino2014-07-282-8/+8 * - Add LICENSEsunpoet2014-07-171-0/+2 * 1: remove NO_STAGE.vanilla2014-07-161-2/+1 * Resetting maintainership on ports that have not been staged and without anybapt2014-07-035-5/+5 * Stagify.vanilla2014-07-024-22/+32 * Update to 4.2.5.jkim2014-06-241-4/+4 * Update to libreoffice 4.2.4bapt2014-06-111-4/+4 * vietnamese/vis2u: Fix EXTRACT_AFTER_ARGSmarino2014-06-011-2/+1 * vietnamese/unicode-uhoai: Fix deinstall and add stage supportmarino2014-05-313-10/+19 * KDE/FreeBSD team presents KDE SC 4.12.5 and KDE Workspace 4.11.9!makc2014-05-111-2/+2 * Update to 4.1.6.jkim2014-05-071-4/+4 * Mark broken: Conflicts with dependency vnpstext on share/vn-fonts/initcour.psantoine2014-04-061-0/+2 * KDE/FreeBSD team presents KDE SC 4.12.4 and KDE Workspace 4.11.8!makc2014-04-031-2/+2 * Support stagingehaupt2014-03-172-10/+12 * Stagify, generally cleanup Makefile, provide more useful port description.danfe2014-03-162-17/+23 * Support stagingehaupt2014-03-132-6/+5 * Unbreakantoine2014-03-121-1/+1 * Unbreakantoine2014-03-121-1/+1 * Convert u* and v* to USES=zipbapt2014-03-117-7/+7 * KDE/FreeBSD team presents KDE SC 4.12.3 and KDE Workspace 4.11.7!makc2014-03-051-2/+2 * Support stagingehaupt2014-02-271-4/+2 * - Stage supportmiwi2014-02-263-7/+6 * Update to 4.1.5. It is partially based on the following PR.jkim2014-02-261-4/+4 * KDE/FreeBSD team presents KDE SC 4.12.2 and KDE Workspace 4.11.6!makc2014-02-183-6/+23 * Fix properties on pkg-plistbapt2014-01-2210-10/+0 * Support stagebapt2014-01-203-7/+5 * - Use single space after WWW:sunpoet2013-11-181-1/+1 * Support stage, use bsdtar to extractbapt2013-11-041-4/+3 * Stagifybapt2013-11-041-1/+0 * - Update to 4.0.6.jkim2013-10-262-5/+4 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-2121-110/+39 * Update to 4.0.5.jkim2013-08-231-4/+4 * KDE3 and QT3 expired on 2013-07-01, remove these ports.rene2013-07-275-369/+0 * Fix INDEX by really fixing the kde4-l10n portsbapt2013-07-101-0/+1 * KDE4 l10n fixes.rakuco2013-07-101-2/+1 * Update the KDE Software Compilation to 4.10.5.rakuco2013-07-051-2/+2 * Update to KDE SC 4.10.4, proudly presented by the KDE on FreeBSD team.rakuco2013-07-031-2/+2 * Update to 4.0.4.jkim2013-06-201-4/+4 * - Fix ttfm's xttfm module to really update fonts.{dir,scale} to reflectrafan2013-06-204-4/+4 * Fix build with clangbapt2013-05-271-2/+11 * KDE/FreeBSD team presents KDE SC 4.10.3 ports!makc2013-05-192-4/+2 * Rectify USE_TEX to support both of teTeX and TeXLive.hrs2013-05-121-1/+1 * Update to 4.0.3.jkim2013-05-101-4/+4 * Remove *_DEPENDS from ports which depend on teTeX and add USE_TEX=tetexhrs2013-05-061-3/+1 * - Convert USE_GETTEXT to USES (part 2)ak2013-04-241-1/+1 * Update to 4.0.2.jkim2013-04-171-4/+4 * KDE/FreeBSD team presents KDE SC 4.10.1 ports!makc2013-03-273-5/+12 * 2013-03-05 ftp/proma: Broken for more than 6 monthbapt2013-03-1033-2132/+0 * Update to 4.0.1.jkim2013-03-09