aboutsummaryrefslogtreecommitdiffstats
path: root/irc/scrollz
diff options
context:
space:
mode:
Diffstat (limited to 'irc/scrollz')
-rw-r--r--irc/scrollz/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/irc/scrollz/Makefile b/irc/scrollz/Makefile
index d5dd8a2590b6..f120c7ef04d5 100644
--- a/irc/scrollz/Makefile
+++ b/irc/scrollz/Makefile
@@ -31,6 +31,12 @@ GNUTLS_CONFIGURE_ON= --with-ssl
OPENSSL_USE= OPENSSL=yes
OPENSSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
+.include <bsd.port.pre.mk>
+
+.if !empty(ICONV_LIB)
+CONFIGURE_ENV+=ac_cv_func_iconv_open=yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
@@ -46,4 +52,4 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${i}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>