aboutsummaryrefslogtreecommitdiffstats
path: root/irc/sirc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/sirc/Makefile')
-rw-r--r--irc/sirc/Makefile79
1 files changed, 79 insertions, 0 deletions
diff --git a/irc/sirc/Makefile b/irc/sirc/Makefile
new file mode 100644
index 000000000000..bba11bd2ab27
--- /dev/null
+++ b/irc/sirc/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: sirc
+# Version required: 2.211
+# Date created: 4 May 1998
+# Whom: Studded <Studded@dal.net>
+#
+# $Id$
+#
+# If you need SOCKS support, define SOCKS_SERVER with
+# the name of your SOCKS proxy and remove the '#'.
+# You should also check the default port and DNS
+# setting in ${PREFIX}/bin/sirc after installation.
+#
+# SOCKS_SERVER= your.socks.proxy
+
+DISTNAME= sirc-2.211
+CATEGORIES= net
+MASTER_SITES= http://www.eleves.ens.fr:8080/home/espel/sirc/ \
+ ftp://ftp1.dal.net/dalnet/clients/unix/sirc/ \
+ ftp://ftp2.dal.net/dalnet/clients/unix/sirc/
+
+MAINTAINER= Studded@dal.net
+
+USE_PERL5= yes
+
+post-extract:
+.if !defined(SOCKS_SERVER)
+ @${ECHO_MSG} ''
+ @${ECHO_MSG} "SOCKS proxy support is available with this client."
+ @${ECHO_MSG} "If you need SOCKS support edit the Makefile in this"
+ @${ECHO_MSG} "directory according to the instructions at the top of it."
+ @${ECHO_MSG} "Then do 'make clean', 'make deinstall' (if needed)"
+ @${ECHO_MSG} "then 'make install'."
+ @${ECHO_MSG} ''
+.endif
+
+pre-patch:
+ @${CP} ${SCRIPTDIR}/sirc-proto ${WRKSRC}
+
+do-patch:
+.if defined(SOCKS_SERVER)
+ @${PATCH} ${PATCH_DIST_ARGS} < ${PATCHDIR}/patch-aa
+ @${SED} 's%SOCKS_SERVER\=%SOCKS_SERVER\=${SOCKS_SERVER}%' \
+ ${WRKSRC}/sirc-proto > ${WRKSRC}/sirc-socks
+ @${SED} 's%PREFIX\=%PREFIX\=${PREFIX}%' ${WRKSRC}/sirc-socks \
+ > ${WRKSRC}/sirc
+.else
+ @${SED} 's%PREFIX\=%PREFIX\=${PREFIX}%' ${WRKSRC}/sirc-proto \
+ > ${WRKSRC}/sirc
+.endif
+
+NO_CONFIGURE= "There is no configure or makefile in the source"
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/ssfe.c -o ${WRKSRC}/ssfe -ltermcap
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/sirc
+ ${INSTALL_DATA} ${WRKSRC}/n0thing.pl ${PREFIX}/libexec/sirc
+ ${INSTALL_DATA} ${WRKSRC}/sirc.help.gz ${PREFIX}/libexec/sirc
+ ${INSTALL_DATA} ${WRKSRC}/socks.pl ${PREFIX}/libexec/sirc
+ ${INSTALL_SCRIPT} ${WRKSRC}/dsirc ${PREFIX}/libexec/sirc
+ ${INSTALL_PROGRAM} ${WRKSRC}/ssfe ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/sirc ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ssfe.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/sirc.1 ${PREFIX}/man/man1
+.if defined(SOCKS_SERVER)
+ ${ECHO} '&load("socks.pl");' >> ${PREFIX}/libexec/sirc/sircrc.pl
+.endif
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/libexec/sirc
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/libexec/sirc
+ ${INSTALL_DATA} ${WRKSRC}/PROGRAMMING ${PREFIX}/libexec/sirc
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/libexec/sirc
+ ${INSTALL_DATA} ${WRKSRC}/README.socks ${PREFIX}/libexec/sirc
+.endif
+
+MAN1= sirc.1 ssfe.1
+
+.include <bsd.port.mk>