aboutsummaryrefslogtreecommitdiffstats
path: root/irc/weechat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/weechat/Makefile')
-rw-r--r--irc/weechat/Makefile29
1 files changed, 20 insertions, 9 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index a12545102e28..a8938d0609ac 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= weechat
PORTVERSION= 0.3.8
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://weechat.org/files/src/
@@ -20,24 +21,26 @@ CONFLICTS= weechat-devel-0.*
USE_ICONV= yes
USE_LDCONFIG= yes
USE_NCURSES= yes
+WITH_NCURSES_PORT= yes
USE_CMAKE= yes
+CMAKE_ARGS+= -DNCURSES_INCLUDE_PATH=${LOCALBASE}/include/ncurses
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
WANT_PERL= yes
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
-OPTIONS_DEFINE= RUBY PYTHON PERL TCL LUA GUILE CHARSET BACKTRACE ASPELL GNUTLS NLS DOCUMENTATION
+OPTIONS_DEFINE= RUBY PYTHON PERL TCL LUA GUILE CHARSET BACKTRACE ASPELL GNUTLS NLS DOCUMENTATION SASL
OPTIONS_DEFAULT=CHARSET
-BACKTRACE_DESC= Enable crash backtraces
-CHARSET_DESC= Enable charset conversion support
+BACKTRACE_DESC= Provide crash backtraces
+CHARSET_DESC= Charset conversion support
DOCUMENTATION_DESC= Build and install documentation
-GUILE_DESC= Enable Guile scripting support
-LUA_DESC= Enable Lua scripting support
-PERL_DESC= Enable Perl scripting support
-PYTHON_DESC= Enable Python scripting support
-RUBY_DESC= Enable Ruby scripting support
-TCL_DESC= Enable Tcl scripting support
+GUILE_DESC= Guile scripting support
+LUA_DESC= Lua scripting support
+PERL_DESC= Perl scripting support
+PYTHON_DESC= Python scripting support
+RUBY_DESC= Ruby scripting support
+TCL_DESC= Tcl scripting support
.include <bsd.port.options.mk>
@@ -143,6 +146,14 @@ PLIST_SUB+= DOCUMENTATION="@comment "
LIB_DEPENDS+= execinfo:${PORTSDIR}/devel/libexecinfo
.endif
+.if ${PORT_OPTIONS:MSASL}
+LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
+PLIST_SUB+= SASL=""
+.else
+CMAKE_ARGS+= -DENABLE_SASL=no
+PLIST_SUB+= SASL="@comment "
+.endif
+
MAN1= weechat-curses.1
post-patch: