aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
Diffstat (limited to 'irc')
-rw-r--r--irc/atheme-services/Makefile2
-rw-r--r--irc/irc/Makefile1
-rw-r--r--irc/ircd-ratbox/Makefile2
-rw-r--r--irc/irssi/Makefile2
4 files changed, 3 insertions, 4 deletions
diff --git a/irc/atheme-services/Makefile b/irc/atheme-services/Makefile
index 3e474091a602..9b69708cb6fd 100644
--- a/irc/atheme-services/Makefile
+++ b/irc/atheme-services/Makefile
@@ -29,7 +29,7 @@ LIB_DEPENDS+= libmowgli-2.so:devel/libmowgli2
USE_RC_SUBR= atheme-services
OPTIONS_DEFINE= CONTRIB CRACKLIB DOCS LDAP NLS PCRE PERL
-OPTIONS_DEFAULT= CRACKLIB DOCS LDAP NLS PCRE PERL
+OPTIONS_DEFAULT= CRACKLIB LDAP PCRE PERL
CONTRIB_DESC= Enable contrib modules
CRACKLIB_DESC= Use cracklib for checking password strength
diff --git a/irc/irc/Makefile b/irc/irc/Makefile
index 5641c894950e..0f9f8bc9f115 100644
--- a/irc/irc/Makefile
+++ b/irc/irc/Makefile
@@ -24,7 +24,6 @@ CONFIGURE_WRKSRC= ${WRKSRC}/build
CONFIGURE_SCRIPT= support/configure
OPTIONS_DEFINE= IPV6
-OPTIONS_DEFAULT=IPV6
IPV6_CONFIGURE_ENABLE= ipv6
post-configure:
diff --git a/irc/ircd-ratbox/Makefile b/irc/ircd-ratbox/Makefile
index 7d1b6bd11887..71a6a9771238 100644
--- a/irc/ircd-ratbox/Makefile
+++ b/irc/ircd-ratbox/Makefile
@@ -58,7 +58,7 @@ SMALL_NET_DESC= Tune server internals for small networks
SERVICES_DESC= Enable ratbox-services compatibility code
SHORTCUTS_DESC= Build with ircd-shortcut commands
-OPTIONS_DEFAULT= OPENSSL IPV6 ZIPLINKS SHARED_MODS
+OPTIONS_DEFAULT= OPENSSL ZIPLINKS SHARED_MODS
OPTIONS_EXCLUDE= NLS EXAMPLES
OPTIONS_SUB= yes
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index b41218ba5482..d9a89feea109 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ARGS= --with-ncurses=${NCURSESBASE}
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= PERL PROXY SOCKS IPV6 BOT DOCS TRUECOLOR
-OPTIONS_DEFAULT= PERL IPV6 DOCS
+OPTIONS_DEFAULT= PERL
OPTIONS_SUB= yes
SOCKS_DESC= Socks proxy support
SOCKS_CONFIGURE_WITH= socks