aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
Diffstat (limited to 'irc')
-rw-r--r--irc/irssi-otr/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/irc/irssi-otr/Makefile b/irc/irssi-otr/Makefile
index 44cfcc464129..235fee134eac 100644
--- a/irc/irssi-otr/Makefile
+++ b/irc/irssi-otr/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libotr.so:${PORTSDIR}/security/libotr \
libgcrypt.so:${PORTSDIR}/security/libgcrypt
RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
-USES= pkgconfig
+USES= autoreconf libtool pkgconfig
USE_LDCONFIG= yes
USE_GNOME= glib20
USE_GITHUB= yes
@@ -28,12 +28,8 @@ GH_PROJECT= ${PORTNAME}
GH_COMMIT= f4ecd19
GH_TAGNAME= v${PORTVERSION}
-USE_AUTOTOOLS= autoconf aclocal libtoolize automake
-ACLOCAL_ARGS= -I config
-AUTOMAKE_ARGS= --add-missing --no-force
-
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${LOCALBASE} --with-libotr-inc-prefix=${LOCALBASE}/include
+CONFIGURE_ARGS= --with-libotr-inc-prefix=${LOCALBASE}/include
INSTALL_TARGET= install-strip
PLIST_FILES= lib/irssi/modules/libotr.so \