aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
Diffstat (limited to 'irc')
-rw-r--r--irc/ircservices/Makefile36
1 files changed, 19 insertions, 17 deletions
diff --git a/irc/ircservices/Makefile b/irc/ircservices/Makefile
index 9882524dd0e2..1f2ee1099aef 100644
--- a/irc/ircservices/Makefile
+++ b/irc/ircservices/Makefile
@@ -11,23 +11,25 @@ MASTER_SITES= http://www.ircservices.za.net/download/ \
MAINTAINER= rum1cro@yandex.ru
COMMENT= A system of IRC services for IRC networks
+LICENSE= GPLv2
+
USES= gmake perl5
+USE_GCC= any
USE_PERL5= build
HAS_CONFIGURE= yes
USE_RC_SUBR= ircservices
+SUB_FILES= pkg-message
DIST_SUBDIR= ${PORTNAME}
-CONFIGURE_ARGS= -bindest ${PREFIX}/sbin -datdest ${PREFIX}/etc/ircservices -cflags "${CFLAGS}" -cc "${CC}"
+CONFIGURE_ARGS= -bindest ${PREFIX}/sbin -datdest ${PREFIX}/etc/ircservices \
+ -cflags "${CFLAGS}" -cc "${CC}"
+MAKE_JOBS_UNSAFE= yes
+NEED_ROOT= yes
IRCSERVICES_LANG?= EN_US
-NO_STAGE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 700042
-CFLAGS+= -fno-stack-protector
-.endif
-
.if ${ARCH} == "amd64"
CFLAGS+= -fPIC
.endif
@@ -41,19 +43,19 @@ pre-patch:
@${ECHO_MSG} "DE EN_US ES FR HU IT JA_EUC JA_SJIS NL PT TR"
post-patch:
- @${REINPLACE_CMD} -e 's|LANG_EN_US|LANG_${IRCSERVICES_LANG}|' \
+ @${REINPLACE_CMD} -e 's#LANG_EN_US#LANG_${IRCSERVICES_LANG}#' \
${WRKSRC}/defs.h
+post-build:
+ @${REINPLACE_CMD} -e 's#BINDEST=.*#BINDEST=${STAGEDIR}${PREFIX}/sbin# ; \
+ s#DATDEST=.*#DATDEST=${STAGEDIR}${PREFIX}/etc/ircservices#' \
+ ${WRKSRC}/Makefile.inc
+ @${REINPLACE_CMD} -e 's#@BINDEST@#${PREFIX}/sbin# ; \
+ s#@DATDEST@#${PREFIX}/etc/ircservices#' \
+ ${WRKSRC}/tools/ircservices-chk.in
+
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} \* ${DOCSDIR})
- @${ECHO_MSG} ""
- @${ECHO_MSG} "********** IMPORTANT **********"
- @${ECHO_MSG} "The configuration directory has changed to ${PREFIX}/etc/ircservices"
- @${ECHO_MSG} "Please copy your old config files there if updating"
- @${ECHO_MSG} "********** IMPORTANT *********"
- @${ECHO_MSG} ""
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR})
.include <bsd.port.post.mk>
he GTK/Imlib dependency. The gtk client is (imo) horrible.cpiazza1999-09-282-8/+4 * oops, forgot two patches in the upgrade to version 1.11cpiazza1999-09-282-0/+19 * Update to version 1.11cpiazza1999-09-284-21/+30 * Don't call cc(1) with OSF/1 style arguments on FreeBSD/Alpha.steve1999-09-273-0/+33 * Turn (back) on sound support for FreeBSD/Alpha.steve1999-09-265-17/+1 * Add sltaoka1999-09-251-0/+1 * A steam locomotive run on the screen if you type "sl" instead of "ls"taoka1999-09-255-0/+46 * These ports are building now, so take out BROKEN_ELF.asami1999-09-211-2/+0 * s/chtype/chartype/g so this builds on FreeBSD/Alpha too.steve1999-09-203-0/+58 * We no longer need to define SPECIAL_BSD to coverup for an old cursessteve1999-09-201-10/+3 * Updated to version 1.4.4jim1999-09-192-3/+3 * Update to KDE-1.1.2se1999-09-1812-20/+276 * The version number of libgif.so has changed to 5.steve1999-09-185-5/+5 * Resolve many 301 Moved Permanently URLs in DESCR.fenner1999-09-185-5/+5 * Unbreak this port, thanks to suggestions made bydburr1999-09-111-4/+2 * Upgrade to 16.18.mph1999-09-112-5/+5 * Add a patch to unbreak for gcc 2.95.1cpiazza1999-09-103-0/+282 * Add a couple of master sites.tg1999-09-091-1/+4 * Add columnstaoka1999-09-091-0/+1 * I'm giving up trying to talk to foxfair about this. ;)asami1999-09-091-1/+1 * Nice little implementation of columns game for X Window Systemtaoka1999-09-096-0/+137 * One line change for COMMENT. Make it more readable.foxfair1999-09-091-1/+1 * Updated to version 1.1-1jim1999-09-082-9/+7 * Active xphotohunter.foxfair1999-09-071-0/+1 * Re-import xphotohunter to the RIGHT place.foxfair1999-09-076-0/+145 * The tiff port now lives in ports/graphics/tiff.steve1999-09-071-1/+1 * Update to version 990905cpiazza1999-09-073-12/+14 * Remove the BROKEN tag on this with usage of find and perl.cpiazza1999-09-022-12/+2 * Er, really update to 990901, but this is now marked BROKEN becausecpiazza1999-09-022-1/+3 * Update to version 990901cpiazza1999-09-021-2/+2 * FreeBSD.ORG -> FreeBSD.orgmharo1999-08-3148-63/+63 * Upgrade to 16.17.mph1999-08-312-5/+5 * Upgrade to 4.0pl80.mph1999-08-303-17/+8 * Update to version 4.0.3cpiazza1999-08-302-5/+5 * Update to 990829cpiazza1999-08-302-4/+5 * Remove preceeding pkgname from some of the comments having one.hoek1999-08-303-3/+3 * $Id$ -> $FreeBSD$peter1999-08-299-9/+9 * expr -> ${EXPR}mharo1999-08-283-3/+3 * sed -> ${SED}mharo1999-08-281-1/+1 * Fix package building errors.jim1999-08-281-1/+1 * echo -> ${ECHO} or ${ECHO_MSG} and in some cases, move echo stuffmharo1999-08-2810-21/+22 * Add a trailing '/' to the end of a MASTER_SITEcpiazza1999-08-271-1/+1 * I should have read the web page a little closer, the program'scpiazza1999-08-261-2/+2 * Distfile changed without a version bumpcpiazza1999-08-261-1/+1 * backout change by obrienmharo1999-08-251-31/+10 * Update to version 0.43cpiazza1999-08-253-5/+9 * Change Id->FreeBSD.obrien1999-08-25