aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/nethack34/files/patch-ag
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/nethack34/files/patch-ag')
-rw-r--r--japanese/nethack34/files/patch-ag42
1 files changed, 21 insertions, 21 deletions
diff --git a/japanese/nethack34/files/patch-ag b/japanese/nethack34/files/patch-ag
index 89eb18e12d3f..56aed0a0e35b 100644
--- a/japanese/nethack34/files/patch-ag
+++ b/japanese/nethack34/files/patch-ag
@@ -1,21 +1,21 @@
-diff -ruN ./src/polyself.c ../nethack-3.2.2/src/polyself.c
---- ./src/polyself.c Sun Nov 22 01:10:08 1998
-+++ ../nethack-3.2.2/src/polyself.c Sun Nov 22 01:12:25 1998
-@@ -171,7 +171,7 @@
- if (u.uhp <= 0) u.uhp = 1;
- if (u.uhpmax <= 0) u.uhpmax = 1;
- } else {
--/*JP Your("new form doesn't seem healthy enough to survive.");
-+/*JP Your("new form doesn't seem healthy enough to survive.");*/
- Your("新しい姿は生きてくだけの力がないようだ.");
- killer_format = KILLED_BY_AN;
- /*JP killer="unsuccessful polymorph";*/
-@@ -181,7 +181,7 @@
- }
- /*JP polyman("feel like a new %s!",
- Role_is('E') ? "elf" : flags.female ? "woman" : "man");*/
-- if(saved_sex == flags.female)
-+ if(u.umonnum != PM_PLAYERMON || saved_sex == flags.female)
- polyman("別の%sとして生まれかわったような気がした!",
- pl_character[0] == 'E' ? "エルフ" : "人間");
- else
+--- sys/unix/Makefile.utl.orig Sun Jun 16 03:02:10 2002
++++ sys/unix/Makefile.utl Sun Jun 16 03:13:16 2002
+@@ -89,7 +89,17 @@
+ # flags for debugging:
+ # CFLAGS = -g -I../include
+
+-CFLAGS = -O -I../include
++CFLAGS += -I../include
++ifeq ("$(GRAPHICS)","X11_GRAPHICS")
++CFLAGS += -DX11_GRAPHICS
++endif
++ifeq ("$(GRAPHICS)","QT_GRAPHICS")
++CFLAGS += -DQT_GRAPHICS
++endif
++ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
++CFLAGS += -DGNOME_GRAPHICS
++endif
++
+ LFLAGS =
+
+ LIBS =