aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/postgresql-tcltk/files
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/postgresql-tcltk/files')
-rw-r--r--japanese/postgresql-tcltk/files/patch-ab41
-rw-r--r--japanese/postgresql-tcltk/files/patch-ac22
-rw-r--r--japanese/postgresql-tcltk/files/patch-ad20
-rw-r--r--japanese/postgresql-tcltk/files/patch-ae11
-rw-r--r--japanese/postgresql-tcltk/files/patch-af25
-rw-r--r--japanese/postgresql-tcltk/files/patch-ag11
-rw-r--r--japanese/postgresql-tcltk/files/patch-bc5
-rw-r--r--japanese/postgresql-tcltk/files/pgsql.sh.tmpl53
-rw-r--r--japanese/postgresql-tcltk/files/post-install-notes18
9 files changed, 120 insertions, 86 deletions
diff --git a/japanese/postgresql-tcltk/files/patch-ab b/japanese/postgresql-tcltk/files/patch-ab
index cb53b5b7de93..3be237663dd4 100644
--- a/japanese/postgresql-tcltk/files/patch-ab
+++ b/japanese/postgresql-tcltk/files/patch-ab
@@ -1,25 +1,22 @@
---- bin/pg_passwd/pg_passwd.c.orig Thu May 27 16:00:40 1999
-+++ bin/pg_passwd/pg_passwd.c Tue Jun 15 19:27:47 1999
-@@ -26,11 +26,17 @@
+--- bin/pg_passwd/pg_passwd.c.orig Mon Apr 17 12:45:18 2000
++++ bin/pg_passwd/pg_passwd.c Wed May 10 03:39:18 2000
+@@ -18,11 +18,14 @@
#endif
+#ifndef _POSIX_SOURCE
-+# define _PASSWORD_LEN 128 /* max length, not containing NULL */
++# define _PASSWORD_LEN 128 /* max length, not containing NULL */
+#endif
-+
-+
char *comname;
- static void usage(FILE *stream);
- static void read_pwd_file(char *filename);
-+static void encrypt_pwd(char key[9], char salt[3], char passwd[_PASSWORD_LEN+1]);
-+int check_pwd(char key[9], char passwd[_PASSWORD_LEN+1]);
- static void write_pwd_file(char *filename, char *bkname);
--static void encrypt_pwd(char key[9], char salt[3], char passwd[14]);
- static void prompt_for_username(char *username);
- static void prompt_for_password(char *prompt, char *password);
+ static void usage(FILE *stream);
+ static void read_pwd_file(char *filename);
+ static void write_pwd_file(char *filename, char *bkname);
+-static void encrypt_pwd(char key[9], char salt[3], char passwd[14]);
++static void encrypt_pwd(char key[9], char salt[3], char passwd[_PASSWORD_LEN+1]);
+ static void prompt_for_username(char *username);
+ static void prompt_for_password(char *prompt, char *password);
-@@ -158,7 +164,7 @@
+@@ -150,7 +153,7 @@
if (q != NULL)
*(q++) = '\0';
@@ -28,7 +25,7 @@
{
fprintf(stderr, "WARNING: %s: line %d: illegal password length.\n",
filename, npwds + 1);
-@@ -222,7 +228,7 @@
+@@ -214,7 +217,7 @@
}
static void
@@ -37,26 +34,28 @@
{
int n;
-@@ -254,9 +260,7 @@
+@@ -246,9 +249,9 @@
#ifdef NOT_USED
static int
-check_pwd(char key[9], char passwd[14])
++check_pwd(char key[9], char passwd[_PASSWORD_LEN+1])
{
- char shouldbe[14];
++ char shouldbe[_PASSWORD_LEN+1];
char salt[3];
salt[0] = passwd[0];
-@@ -264,7 +268,7 @@
+@@ -256,7 +259,7 @@
salt[2] = '\0';
encrypt_pwd(key, salt, shouldbe);
- return strncmp(shouldbe, passwd, 13) == 0 ? 1 : 0;
-+ return strncmp(shouldbe, passwd, _PASSWORD_LEN) == 0 ? 1 : 0;
++ return strncmp(shouldbe, passwd, _PASSWORD_LEN+1) == 0 ? 1 : 0;
}
- #endif
-@@ -339,7 +343,7 @@
+ #endif
+@@ -332,7 +335,7 @@
char salt[3];
char key[9],
key2[9];
diff --git a/japanese/postgresql-tcltk/files/patch-ac b/japanese/postgresql-tcltk/files/patch-ac
index 2a9e180e0958..f0f0ac586e74 100644
--- a/japanese/postgresql-tcltk/files/patch-ac
+++ b/japanese/postgresql-tcltk/files/patch-ac
@@ -1,11 +1,11 @@
---- interfaces/libpgtcl/Makefile.in.orig Mon Feb 8 07:10:45 1999
-+++ interfaces/libpgtcl/Makefile.in Tue Jun 15 19:32:36 1999
-@@ -27,7 +27,7 @@
-
- OBJS= pgtcl.o pgtclCmds.o pgtclId.o
-
--SHLIB_LINK+= -L../libpq -lpq
-+SHLIB_LINK+= -L../libpq -lpq -lcrypt
-
- # If crypt is a separate library, rather than part of libc, it may need
- # to be referenced separately to keep (broken) linkers happy. (This is
+--- configure.orig Thu May 4 04:10:55 2000
++++ configure Wed May 10 03:46:37 2000
+@@ -1472,7 +1472,7 @@
+ ELF_SYS=true
+ else
+ rm -rf conftest*
+- if test "X$elf" = "Xyes"
++ if test "X$PORTOBJFORMAT" = "Xelf"
+ then
+ ELF_SYS=true
+ else
diff --git a/japanese/postgresql-tcltk/files/patch-ad b/japanese/postgresql-tcltk/files/patch-ad
index ce5713717369..ea1b852b3f87 100644
--- a/japanese/postgresql-tcltk/files/patch-ad
+++ b/japanese/postgresql-tcltk/files/patch-ad
@@ -1,13 +1,11 @@
---- pl/tcl/Makefile.org Mon Dec 14 08:47:17 1998
-+++ pl/tcl/Makefile Thu Feb 25 22:20:28 1999
-@@ -55,8 +55,8 @@
- SHLIB_EXTRA_LIBS=
- endif
+--- Makefile.global.in.orig Wed May 10 03:47:24 2000
++++ Makefile.global.in Wed May 10 03:48:37 2000
+@@ -87,7 +87,7 @@
+ POSTMANDIR= $(POSTGRESDIR)/man
--%$(TCL_SHLIB_SUFFIX): %.o
-- $(TCL_SHLIB_LD) -o $@ $< $(TCL_LIB_SPEC) $(SHLIB_EXTRA_LIBS)
-+#%$(TCL_SHLIB_SUFFIX): %.o
-+# $(TCL_SHLIB_LD) -o $@ $< $(TCL_LIB_SPEC) $(SHLIB_EXTRA_LIBS)
+ # Where the formatted documents (e.g., the reference manual) get installed.
+-POSTDOCDIR= $(POSTGRESDIR)/doc
++POSTDOCDIR= !!PREFIX!!/share/doc/pgsql
-
- #
+ # Where the header files necessary to build frontend programs get installed.
+ HEADERDIR= $(POSTGRESDIR)/include
diff --git a/japanese/postgresql-tcltk/files/patch-ae b/japanese/postgresql-tcltk/files/patch-ae
new file mode 100644
index 000000000000..82a8e0012494
--- /dev/null
+++ b/japanese/postgresql-tcltk/files/patch-ae
@@ -0,0 +1,11 @@
+--- ../doc/Makefile.orig Mon Dec 6 06:23:00 1999
++++ ../doc/Makefile Wed May 10 03:50:13 2000
+@@ -12,7 +12,7 @@
+ #
+ #----------------------------------------------------------------------------
+
+-PGDOCS= $(POSTGRESDIR)/doc
++PGDOCS= $(POSTDOCDIR)
+ SRCDIR= ../src
+
+ TAR= tar
diff --git a/japanese/postgresql-tcltk/files/patch-af b/japanese/postgresql-tcltk/files/patch-af
new file mode 100644
index 000000000000..58d833335108
--- /dev/null
+++ b/japanese/postgresql-tcltk/files/patch-af
@@ -0,0 +1,25 @@
+--- interfaces/jdbc/Makefile.orig Tue May 9 12:47:50 2000
++++ interfaces/jdbc/Makefile Wed May 10 03:53:41 2000
+@@ -10,10 +10,10 @@
+
+ FIND = find
+ IDL2JAVA = idltojava -fno-cpp -fno-tie
+-JAR = jar
+-JAVA = java
+-JAVAC = javac -g
+-JAVADOC = javadoc
++JAR = !!JAVA_HOME!!/bin/jar
++JAVA = !!JAVA_HOME!!/bin/java
++JAVAC = !!JAVA_HOME!!/bin/javac
++JAVADOC = !!JAVA_HOME!!/bin/javadoc
+ RM = rm -f
+ TOUCH = touch
+
+@@ -49,6 +49,7 @@
+ @echo JVM.
+ @echo
+ @echo ------------------------------------------------------------
++ $(MAKE) jdbc1
+
+ msg:
+ @echo ------------------------------------------------------------
diff --git a/japanese/postgresql-tcltk/files/patch-ag b/japanese/postgresql-tcltk/files/patch-ag
new file mode 100644
index 000000000000..e15a1521b855
--- /dev/null
+++ b/japanese/postgresql-tcltk/files/patch-ag
@@ -0,0 +1,11 @@
+--- pl/tcl/Makefile.orig Sun Apr 30 02:45:42 2000
++++ pl/tcl/Makefile Fri May 12 21:31:07 2000
+@@ -66,7 +66,7 @@
+ # Instead use TCL's CFLAGS plus necessary -I directives.
+
+ # Can choose either TCL_CFLAGS_OPTIMIZE or TCL_CFLAGS_DEBUG here, as needed
+-CFLAGS= $(TCL_CFLAGS_OPTIMIZE)
++CFLAGS+= $(TCL_CFLAGS_OPTIMIZE)
+
+ CFLAGS+= $(TCL_SHLIB_CFLAGS) $(TCL_DEFS)
+
diff --git a/japanese/postgresql-tcltk/files/patch-bc b/japanese/postgresql-tcltk/files/patch-bc
new file mode 100644
index 000000000000..e4e98dd945b0
--- /dev/null
+++ b/japanese/postgresql-tcltk/files/patch-bc
@@ -0,0 +1,5 @@
+--- bin/pg_ctl/postmaster.opts.default.sample.org Tue Jun 6 15:23:50 2000
++++ bin/pg_ctl/postmaster.opts.default.sample Tue Jun 6 15:24:08 2000
+@@ -1 +1 @@
+-
++-i -o "-F"
diff --git a/japanese/postgresql-tcltk/files/pgsql.sh.tmpl b/japanese/postgresql-tcltk/files/pgsql.sh.tmpl
index d3f0af6cb802..e1673b4850c2 100644
--- a/japanese/postgresql-tcltk/files/pgsql.sh.tmpl
+++ b/japanese/postgresql-tcltk/files/pgsql.sh.tmpl
@@ -1,39 +1,34 @@
#!/bin/sh
# $FreeBSD$
-
-# pgsql.sh - postgresql startup file for FreeBSD and possibly *BSD (untested)
-
-# Changes:
-# - renamed startup script to be in sync with INSTALL file
-# - merged ldconfig start sequence from former postgrsql.sh script (andreas)
-# - modified the postmaster startup sequence as suggested in the
-# INSTALL file which was given as example for FreeBSD 2.2 (andreas)
-# - removed the commandline option
-# -D!!PG_PATH!!/data \
-# because the postmaster process, which starts up under the
-# environment of the pgsql user, sets this with the PGDATA
-# environment variable in !!PG_PATH!!/.profile
#
+# For postmaster startup options, edit $PGDATA/postmaster.opts.default
+# Preinstalled options are -i -o "-F"
-case "$1" in
+case $1 in
start)
- [ -d !!PG_PATH!!/lib ] && /sbin/ldconfig -m !!PG_PATH!!/lib
+ [ -d !!PREFIX!!/pgsql/lib ] && /sbin/ldconfig -m !!PREFIX!!/pgsql/lib
+ [ -x !!PREFIX!!/pgsql/bin/pg_ctl ] && {
+ su -l pgsql -c \
+ 'exec !!PREFIX!!/pgsql/bin/pg_ctl -w start > !!PREFIX!!/pgsql/errlog 2>&1'
+ echo -n ' pgsql'
+ }
+ ;;
- [ -x !!PG_PATH!!/bin/postmaster ] && {
- su -l !!PGSQL_UID!! -c 'exec !!PG_PATH!!/bin/postmaster -i -S -o -F \
- -D!!PG_PATH!!/data > !!PG_PATH!!/errlog'
- echo -n ' PostgreSQL'
- }
- ;;
stop)
- # XXX some pgsql user should check this --tg
- killall !!PG_PATH!!/bin/postmaster
- ;;
+ [ -x !!PREFIX!!/pgsql/bin/pg_ctl ] && {
+ su -l pgsql -c 'exec !!PREFIX!!/pgsql/bin/pg_ctl -w -m fast stop'
+ }
+ ;;
+
+status)
+ [ -x !!PREFIX!!/pgsql/bin/pg_ctl ] && {
+ su -l pgsql -c 'exec !!PREFIX!!/pgsql/bin/pg_ctl status'
+ }
+ ;;
+
*)
- echo "Usage: `basename $0` {start|stop}" >&2
- exit 64
- ;;
+ echo "usage: `basename $0` {start|stop|status}" >&2
+ exit 64
+ ;;
esac
-
-exit 0
diff --git a/japanese/postgresql-tcltk/files/post-install-notes b/japanese/postgresql-tcltk/files/post-install-notes
index 4e6e8df02c33..d99f47615730 100644
--- a/japanese/postgresql-tcltk/files/post-install-notes
+++ b/japanese/postgresql-tcltk/files/post-install-notes
@@ -1,24 +1,14 @@
-Now that PostgreSQL-j was installed, you should read the documentation and
+Now that PostgreSQL is installed, you should read the documentation and
implementation guides. These can be found at:
http://www.PostgreSQL.org/docs
-Documentations for the Multibyte-extention can be found at:
-
- doc/README.mb (English)
- doc/README.mb.jp (Japanese)
-
You may wish to subscribe to the PostgreSQL user-support mailing list.
Send an e-mail to pgsql-questions-request@postgresql.org with the
text "subscribe" in the message body.
-If you understand Japanese, you might want to visit:
-
- http://www.sra.co.jp/people/t-ishii/PostgreSQL
-
-to subscribe a local mailing list for Japanese speakers.
-
-If you build PostgreSQL with TCL support, then you can use the
-TCL/TK based database frontend "pgaccess" for database operations.
+If you built PostgreSQL with TCL support, you can install the port
+"pgaccess" to get a TCL/TK based database frontend for database
+operations.