aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/ptex-jis/pkg-deinstall
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/ptex-jis/pkg-deinstall')
-rw-r--r--japanese/ptex-jis/pkg-deinstall14
1 files changed, 14 insertions, 0 deletions
diff --git a/japanese/ptex-jis/pkg-deinstall b/japanese/ptex-jis/pkg-deinstall
new file mode 100644
index 000000000000..c432da27777a
--- /dev/null
+++ b/japanese/ptex-jis/pkg-deinstall
@@ -0,0 +1,14 @@
+#!/bin/sh
+# Preserve files installed by ptex-common, or other package/application.
+#
+files="${PKG_PREFIX}/bin/pltotf ${PKG_PREFIX}/bin/tftopl ${PKG_PREFIX}/share/texmf/web2c/texmf.cnf ${PKG_PREFIX}/share/texmf/ls-R"
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit;
+fi
+
+for f in ${files}; do
+ if [ -f $f.old ]; then
+ mv $f.old $f
+ fi
+done
cgi/freebsd-ports-gnome/commit/x11/libXdamage?h=gstreamer&id=3f8673b5304491d815979cbca9f5698f2e27e181'>At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-121-1/+1 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-111-1/+1 * Remove hardcoding of MTREE_FILE. This is handled in bsd.port.mk sincelesi2005-03-061-1/+0 * Use the right MTREE_FILEarved2004-04-191-0/+1 * SIZEify (maintainer timeout)trevor2004-03-311-0/+1 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-141-1/+1 * Add a missing dependency on xproto.marcus2004-02-221-1/+2 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-0/+1 * Update to 1.0.1anholt2004-01-253-18/+5