aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/trac/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/trac/Makefile')
-rw-r--r--japanese/trac/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/japanese/trac/Makefile b/japanese/trac/Makefile
index 538b67a671e3..9f2f0b0d1607 100644
--- a/japanese/trac/Makefile
+++ b/japanese/trac/Makefile
@@ -7,6 +7,7 @@
PORTNAME= trac
PORTVERSION= 0.9.6
+PORTREVISION= 1
CATEGORIES= japanese www devel python
MASTER_SITES= http://dist.bsdlab.org/ \
http://www.i-act.co.jp/project/products/downloads/
@@ -22,7 +23,8 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/
RUN_DEPENDS= ${BUILD_DEPENDS}
OPTIONS= SILVERCITY "Use Silvercity for syntax highlighting" On \
- DOCUTILS "Allow additional text markup" On
+ DOCUTILS "Allow additional text markup" On \
+ LOCALTZ "Use local TZ in notify mail Date: header" Off
CONFLICTS= trac-0.*
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-ja-1
@@ -61,4 +63,8 @@ RUN_DEPENDS+= ${PREFIX}/bin/source2html.py:${PORTSDIR}/textproc/silvercity
RUN_DEPENDS+= ${PREFIX}/bin/rst2html:${PORTSDIR}/textproc/py-docutils
.endif
+.if defined(WITH_LOCALTZ)
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Notify.py
+.endif
+
.include <bsd.port.post.mk>