aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
Diffstat (limited to 'japanese')
-rw-r--r--japanese/epwutil/Makefile34
-rw-r--r--japanese/epwutil/pkg-plist3
2 files changed, 11 insertions, 26 deletions
diff --git a/japanese/epwutil/Makefile b/japanese/epwutil/Makefile
index a46a00352151..ac6d0936a373 100644
--- a/japanese/epwutil/Makefile
+++ b/japanese/epwutil/Makefile
@@ -3,6 +3,7 @@
PORTNAME= epwutil
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= japanese
MASTER_SITES= http://openlab.ring.gr.jp/edict/epwutil/
@@ -10,34 +11,21 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Utilities to manage Japanese EPWING or Electric-Book based CD-ROM
MAKEFILE= makefile.unx
-MANLANG= ja
EPWPROGS= bookinfo catdump squeeze
-EPWDOCS= epwutil.doc
-EPWDOCDIR= share/doc/epwutil
-NO_STAGE= yes
-do-install:
-.for file in ${EPWPROGS}
- cd ${WRKSRC};\
- ${INSTALL_PROGRAM} ${file} ${PREFIX}/bin;\
- ${INSTALL_MAN} ${file}.man ${MANPREFIX}/man/${MANLANG}/cat1/${file}.1
-.if !defined(NOMANCOMPRESS)
- ${GZIP_CMD} ${MANPREFIX}/man/${MANLANG}/cat1/${file}.1
-.endif
-.endfor
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/${EPWDOCDIR}
- cd ${WRKSRC}; ${INSTALL_DATA} ${EPWDOCS} ${PREFIX}/${EPWDOCDIR}
-.endif
+PLIST_FILES= ${EPWPROGS:S|^|bin/|} ${EPWPROGS:S|^|man/ja/man1/|:S|$|.1.gz|}
+PORTDOCS= epwutil.doc
-post-install:
+OPTIONS_DEFINE= DOCS
+
+do-install:
.for file in ${EPWPROGS}
- ${ECHO_CMD} man/${MANLANG}/cat1/${file}.1${MANEXT} >> ${TMPPLIST}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${file}.man \
+ ${STAGEDIR}${MANPREFIX}/man/ja/man1/${file}.1
.endfor
-.if !defined(NOPORTDOCS)
- ${ECHO_CMD} ${EPWDOCDIR}/${EPWDOCS} >> ${TMPPLIST}
- ${ECHO_CMD} "@dirrm ${EPWDOCDIR}" >> ${TMPPLIST}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/japanese/epwutil/pkg-plist b/japanese/epwutil/pkg-plist
deleted file mode 100644
index 1d4be6d78343..000000000000
--- a/japanese/epwutil/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/bookinfo
-bin/catdump
-bin/squeeze