aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/icanna/Makefile29
-rw-r--r--japanese/icanna/distinfo3
-rw-r--r--japanese/icanna/pkg-descr7
4 files changed, 40 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 7179c49fca2f..99d1c55ea453 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -89,6 +89,7 @@
SUBDIR += hex
SUBDIR += hns
SUBDIR += ical
+ SUBDIR += icanna
SUBDIR += iiimf-le-canna
SUBDIR += iiimf-le-freewnn
SUBDIR += im-ja
diff --git a/japanese/icanna/Makefile b/japanese/icanna/Makefile
new file mode 100644
index 000000000000..d83cabdd3330
--- /dev/null
+++ b/japanese/icanna/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: icanna
+# Date created: 2009/01/08
+# Whom: Takayuki Nakao <t@nakao.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icanna
+PORTVERSION= 0.9.0
+CATEGORIES= japanese
+MASTER_SITES= http://www.ceres.dti.ne.jp/~knak/
+DISTNAME= yc-${YC_VERSION}
+
+MAINTAINER= t@nakao.org
+COMMENT= Canna connector for yc.el via unix domain socket
+
+YC_VERSION= 4.0.13
+
+PLIST_FILES+= bin/icanna
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -o icanna icanna.c
+
+do-install:
+ cd ${WRKSRC} && \
+ ${INSTALL_PROGRAM} icanna ${PREFIX}/bin/icanna
+
+.include <bsd.port.mk>
diff --git a/japanese/icanna/distinfo b/japanese/icanna/distinfo
new file mode 100644
index 000000000000..06e314553adb
--- /dev/null
+++ b/japanese/icanna/distinfo
@@ -0,0 +1,3 @@
+MD5 (yc-4.0.13.tar.gz) = 5cc5f04346b806d4157b4b66d7eba69f
+SHA256 (yc-4.0.13.tar.gz) = 5afd06ea819bbf20f5cbfbcd3c60eb58a50b2ef093defc4c93bfdf8ab69444f3
+SIZE (yc-4.0.13.tar.gz) = 43916
diff --git a/japanese/icanna/pkg-descr b/japanese/icanna/pkg-descr
new file mode 100644
index 000000000000..f2ea1833aa3b
--- /dev/null
+++ b/japanese/icanna/pkg-descr
@@ -0,0 +1,7 @@
+icanna is a connector program between yc.el and Canna server
+via unix domain socket. Since emacs21 or former version does
+not support unix domain socket in elisp itself, icanna helps
+the elisp application to interact with Canna server by relaying
+data between standard input/output and unix domain socket.
+
+WWW: http://www.ceres.dti.ne.jp/~knak/yc.html
2002-03-151-0/+1 * Initial import of Py-gsl 0.0.4kevlo2002-02-151-0/+1 * add clarence 0.1.8ijliao2002-01-311-0/+1 * add ploticus 2.02ijliao2002-01-241-0/+1 * Calcoo is a Gtk-based scientific calculator designed to provide maximumnaddy2002-01-201-0/+1 * Add qscanplot 0.3, a program to extract data from scanned plots, graphs andsobomax2002-01-111-0/+1 * Rough port of JavaNNS 1.0 beta. It runs fine, but complains about notdes2002-01-071-0/+1 * Add ruby-gsl, a Ruby extension library for GSL (GNU Scientificknu2001-12-221-0/+1 * Add xgobi 2001.09, graphical data visualisation tool.petef2001-12-191-0/+1 * add newmatijliao2001-12-061-0/+1 * Add naturalmath-0.5, a script to turn intuitively written math into latexpetef2001-12-031-0/+1 * add fxtijliao2001-11-281-0/+1 * Add pari-devel 2.2.0.a, mathmatics library and advanced calculator package.kuriyama2001-11-271-0/+1 * Remove ports/math/Scilab, because it was superceeded by math/scilab long timesobomax2001-11-271-1/+0 * add bigglesijliao2001-11-251-0/+1 * Add unixstat-5.4, a statistics package designed for use with the Unix shellpetef2001-11-251-0/+1 * Add units-1.74, the GNU version of the units program: unit conversion andpetef2001-11-031-0/+1 * New port py-mpz. This builds the mpz module (an interface to GMP) fromtg2001-10-191-0/+1 * Add math/p5-Math-BigInt, an arbitrary size math package for perl. Thistobez2001-10-131-0/+1 * Add p5-Graph, the Perl module for graph operations.tobez2001-10-101-0/+1 * - Sort entries.knu2001-09-211-2/+3 * Add p5-Math-Base85, a perl extension for base 85 numbers, as referencedtobez2001-09-181-0/+1 * Initial import of kset-0.3.kevlo2001-09-171-0/+1 * Add Math::Pari, a Perl interface to famous library PARI formharo2001-09-111-0/+1 * Add py-gato 0.96.g, a Python-based toolbox to visualise algorithmswjv2001-09-031-0/+1 * Add new port Asir.ume2001-08-301-0/+1 * Add libgmp 2001.08.07, a library for arbitrary precision arithmetic.sobomax2001-08-291-0/+1 * add p5-Date-Handlerpetef2001-08-261-0/+1 * add cxscijliao2001-08-111-0/+1 * add p5-Math-Random-MTijliao2001-07-071-0/+1 * add p5-Math-Randomijliao2001-07-071-0/+1 * Add solitaire, the reference implementation of the Solitairedd2001-06-251-0/+1 * add yacasijliao2001-06-221-0/+1 * add gexprijliao2001-06-141-0/+1 * Add vecfem 3, a program to solve non-linear boundary value problems.will2001-06-111-0/+1 * Add math/libgmp3, version 3.1.1 of the GNU arbitrary precision arithmeticade2001-06-051-0/+1 * add sparijliao2001-06-011-0/+1 * add nautyijliao2001-05-301-0/+1 * Unbreak 'make readmes' (and 'make index', kind of) - remove the math/numpyroam2001-05-281-1/+0 * Unbreak 'make index': remove graphics/shot2png and textproc/shot2txt,roam2001-05-261-0/+1 * Add guppi 0.35.5, a ploting program for GNOME.sobomax2001-05-211-0/+1 * Add ruby-math3d, a Ruby library for mathematics for 3D graphics, whichknu2001-05-081-0/+1 * Add ruby-algebra, a Ruby library for mathematical (algebraic)knu2001-05-081-0/+1 * Numpy is now py-numeric after a repo copy. Add py-numeric17, neededtg2001-05-021-1/+2 * add surfijliao2001-04-241-0/+1 * add rascalijliao2001-04-101-0/+1 * Add mupad, a sophisticated computer algebraic system, like mathematicasf2001-04-041-0/+1 * Add matrix 1.0, a c++ library to manipulate matrices and vectors.will2001-03-311-0/+1 * add rpcijliao2001-03-211-0/+1 * Add ccmath, a mathematics library with many functions.roam2001-03-211-0/+1 * New port:lioux2001-03-131-0/+1 * New port:lioux2001-03-131-0/+1 * Add mtrxmath 0.9.3, a small tool for matrix mathemetics.will2001-03-111-0/+1 * add GiNaC, a C++ library for symbolic mathematical calculationsijliao2001-03-071-0/+1 * readd cln to mathijliao2001-02-121-0/+1 * Add ruby-gnuplot, a pipe-based interface to the gnuplot package forknu2001-02-021-0/+1 * Add ruby-narray, numerical N-dimensional array library for Ruby.knu2001-02-011-0/+1 * Add p5-Set-Window 1.00, a perl module to manage an interval on the integerwill2001-01-041-0/+1 * Add p5-Statistics-Table-F 0.02, perl module for computing the statisticalwill2001-01-041-0/+1 * Add p5-Statistics-OLS 0.07, perl module to perform ordinary least squareswill2001-01-041-0/+1 * Add p5-Statistics-LTU 2.8, a perl implementation of Linear Threshouldwill2001-01-041-0/+1 * Add p5-Statistics-Distributions 0.05, perl module that calculateswill2001-01-041-0/+1 * Add p5-Statistics-Descriptive 2.4, perl module that supplies statisticalwill2001-01-041-0/+1 * Add p5-Math-GMP 1.01, perl module that provides an interface to the GMPwill2001-01-041-0/+1 * Add p5-Math-FixedPrecision 0.11, perl module that provides decimal mathwill2001-01-041-0/+1 * Add p5-Math-Financial 0.76, perl module containing common functions forwill2001-01-041-0/+1 * Add p5-Math-Currency 0.10, perl module for exact currency math withwill2001-01-041-0/+1 * Add p5-Math-BigIntFast 6.0, perl module wrapper for Bit::Vector to providewill2001-01-041-0/+1 * Add p5-Math-Bezier 0.01, perl module to solve Bezier curves.will2001-01-041-0/+1 * Add p5-Bit-Vector 6.0, library of advanced math functions that includes awill2001-01-041-0/+1 * Add p5-Bit-ShiftReg 2.0, perl module implementing various bit shiftingwill2001-01-041-0/+1 * Add p5-Statistics-ChiSquare, answering how random your data is.nbm2001-01-031-0/+1 * Add p5-AI-Perceptron 0.01, a perl module intended as an introduction towill2001-01-011-0/+1 * Add p5-AI-NeuralNet-Mesh 0.44, a perl module implementing an optimized,will2001-01-011-0/+1 * Add p5-AI-NeuralNet-BackProp 0.89, a perl module implementing awill2001-01-011-0/+1 * GLPK -- GNU Linear Programming Kit.demon2000-12-181-0/+1 * Add ruby-bitvector, efficient Ruby bit vector extension.knu2000-11-231-0/+1 * New port: math/grijeh2000-10-281-0/+1 * rng is part of py-numeric now.tg2000-09-271-1/+0 * Add p5-Math-Logic 1.19, a perl module providing pure 2, 3 or multi-valuewill2000-09-211-0/+1 * Add p5-Math-Expr 0.4, a perl module for parsing mathematical expressionswill2000-09-211-0/+1 * Adding thx_1138 version 1.0.5.steve2000-09-181-0/+1 * Activate wingz3.sada2000-09-071-0/+1 * Add scigraphica - a scientific application for data analysis and technicalsobomax2000-08-291-0/+1 * Add physcalc (unversioned), an extremely old (apparently first writtenwill2000-08-281-0/+1 * Add Ruby related ports.knu2000-08-071-0/+1 * Activating the glove and ntl ports.steve2000-07-101-0/+2 * Add concorde, a combinatorial optimization library.will2000-07-041-0/+1 * New port of py-gnuplot - a python interface to the popular gnuplot datasobomax2000-07-041-0/+1 * Add libneural in its new location, moved from devel to math category w/owill2000-06-291-0/+1 * Add pspp, a language for statistics strikingly similar to spss.hoek2000-05-131-0/+1 * Add port for the GNU Scientific Library, a collection of routinestg2000-04-071-0/+1 * Add LinAlg, an extended C++ math library. Unfortunately, it can't be madewill2000-04-071-0/+1 * Activate wmcalcjedgar2000-03-281-0/+1 * Adding slsc version 0.2.3.steve2000-01-291-0/+1 * Activate the grpn port.steve1999-11-271-0/+1 * gtkgraph is in graphics, not math. :)asami1999-11-171-1/+0 * Activate the gtkgraph port.steve1999-11-141-0/+1 * Activate the rcalc and topaz ports.steve1999-11-011-0/+2 * Add ngraphtaoka1999-09-091-0/+1 * $Id$ -> $FreeBSD$peter1999-08-301-1/+1 * Activate netcdf and py-scientific.tg1999-07-301-1/+3 * Add the gnuplot+ and parmetis ports.steve1999-06-091-1/+3 * vtk is now in "math".tg1999-06-011-1/+2 * Activate the PDL port.steve1999-04-031-1/+2 * Activate the snns port.steve1999-04-031-1/+2 * Add fftw and grace.asami1999-03-201-1/+3 * Activate the abs port.steve1999-01-261-1/+2 * Activate the dcdflib port.steve1998-12-241-1/+2 * Activate p5-Set-IntSpan port.steve1998-12-241-1/+2 * Activate xwpljseger1998-12-191-1/+2 * Activate math/spinjseger1998-12-131-1/+2 * Remove LOOP_VAR and replace it with tiny Makefiles using MASTERDIR toasami1998-11-201-2/+3 * Activate gnumeric.vanilla1998-10-261-1/+2 * Activate the add port.steve1998-08-311-1/+2 * Turn on geg.steve1998-08-101-1/+2 * Turn on sc.steve1998-08-101-1/+2 * Turn on superlu.steve1998-08-10