aboutsummaryrefslogtreecommitdiffstats
path: root/java/classpath/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/classpath/Makefile')
-rw-r--r--java/classpath/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index 7e7b6a816d1a..bb11ef2e90cf 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -8,6 +8,7 @@
PORTNAME= classpath
PORTVERSION= 0.92
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_GNU} \
${MASTER_SITE_SAVANNAH}
@@ -18,6 +19,7 @@ COMMENT= A GNU project to create a free Java class library
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+USE_LDCONFIG= yes
USE_JAVA= yes
USE_JIKES= yes
USE_GNOME= gtk20 gdkpixbuf pkgconfig gconf2
@@ -25,7 +27,7 @@ GNU_CONFIGURE= yes
PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} `${PKG_CONFIG} gtk+-2.0 --cflags`" \
LDFLAGS="`${PKG_CONFIG} gtk+-2.0 --libs`"
-CONFIGURE_ARGS= --enable-jni --with-jikes --disable-gtk-peer
+CONFIGURE_ARGS= --enable-jni --with-jikes --disable-gtk-peer --disable-plugin
USE_GMAKE= yes
INFO= hacking tools vmintegration