aboutsummaryrefslogtreecommitdiffstats
path: root/java/classpath/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/classpath/Makefile')
-rw-r--r--java/classpath/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
new file mode 100644
index 000000000000..53ac3169ba91
--- /dev/null
+++ b/java/classpath/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: classpath
+# Date created: Sep 1, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= classpath
+PORTVERSION= 0.10
+CATEGORIES= java
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A GNU project to create free core class libraries
+
+USE_GNOME= gtk20 libartlgpl2 pkgconfig
+USE_JAVA= yes
+USE_JIKES= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INFO= hacking vmintegration
+PLIST_FILES= lib/security/classpath.security
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.for dir in ${PREFIX}/share/classpath ${PREFIX}/lib/classpath
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>