aboutsummaryrefslogtreecommitdiffstats
path: root/java/linux-jdk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/linux-jdk/Makefile')
-rw-r--r--java/linux-jdk/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/java/linux-jdk/Makefile b/java/linux-jdk/Makefile
new file mode 100644
index 000000000000..e06698c8f5dc
--- /dev/null
+++ b/java/linux-jdk/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: linux jdk 1.2.2
+# Version required: 1.2.2
+# Date created: Nov 3 1999
+# Whom: Jose Marques
+#
+# $FreeBSD$
+#
+
+PORTNAME= jdk
+PORTVERSION= 1.2.2
+CATEGORIES= java devel
+MASTER_SITES= ftp://ftp.uk.linux.org/pub/linux/java/JDK-1.2.2/i386/rc4/ \
+ ftp://ftp.tux.org/pub/java/JDK-1.2.2/i386/rc4/
+PKGNAMEPREFIX= linux-
+DISTNAME= jdk-1.2.2-RC4-linux-i386-glibc-2.1.2
+
+MAINTAINER= K.J.Koster@kpn.com
+
+RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
+
+NO_CDROM= "License doesn't allow distribution with fee"
+NO_PACKAGE= "License doesn't allow binary distributions"
+
+ONLY_FOR_ARCHS= i386
+
+USE_BZIP2= YES
+WRKSRC= ${WRKDIR}/jdk1.2.2
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/linux-jdk1.2.2
+ (cd ${WRKSRC} && tar -c -f - .) \
+ | (cd ${PREFIX}/linux-jdk1.2.2 && tar fx -)
+ ${RM} ${PREFIX}/linux-jdk1.2.2/bin/.java_wrapper.orig
+ ${RM} ${PREFIX}/linux-jdk1.2.2/jre/bin/.java_wrapper.orig
+
+.include <bsd.port.mk>