aboutsummaryrefslogtreecommitdiffstats
path: root/java/linux-sun-jdk13/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/linux-sun-jdk13/Makefile')
-rw-r--r--java/linux-sun-jdk13/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/java/linux-sun-jdk13/Makefile b/java/linux-sun-jdk13/Makefile
index 5fccf4d60b66..21174a2b3661 100644
--- a/java/linux-sun-jdk13/Makefile
+++ b/java/linux-sun-jdk13/Makefile
@@ -10,14 +10,11 @@ PORTVERSION= ${JDK_VERSION}
CATEGORIES= java devel
MASTER_SITES= #
PKGNAMEPREFIX= linux-
-DISTFILES= j2sdk-1_3_0_02-linux.bin
+DISTFILES= j2sdk-1_3_1-linux-i386.bin
MAINTAINER= kevlo@FreeBSD.org
-RUN_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base \
- javavm:${PORTSDIR}/java/javavmwrapper
-
-JDK_VERSION= 1.3.0
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
NO_CDROM= "License doesn\'t allow distribution with fee"
RESTRICTED= "Redistribution of repackaged binaries not permitted"
@@ -26,20 +23,24 @@ RESTRICTED= "Redistribution of repackaged binaries not permitted"
IGNORE= "You can not legally distribute binaries"
.endif
-ONLY_FOR_ARCHS= i386
EXTRACT_CMD= # empty
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= #empty
-WRKSRC= ${WRKDIR}/jdk1.3.0_02
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+PLIST_SUB+= TARGET_PREFIX=${TARGET_PREFIX:S/^${PREFIX}\///}
NO_BUILD= yes
+USE_LINUX= yes
+JDK_VERSION= 1.3.1
+ONLY_FOR_ARCHS= i386
+TARGET_PREFIX?= ${PREFIX}/${PKGBASE}${PORTVERSION}
.include <bsd.port.pre.mk>
.for file in ${DISTFILES}
.if !exists(${DISTDIR}/${file})
-IGNORE=You must manually fetch the Java SDK 1.3.0 for Linux archive (j2sdk-1_3_0_02-linux.bin) from http://java.sun.com/j2se/1.3/download-linux.html, place it in ${DISTDIR} and then run make again.
+IGNORE=You must manually fetch the Java 2 Development Kit ${JDK_VERSION} for Linux archive (${DISTFILES}) from http://java.sun.com/j2se/1.3/download-linux.html, place it in ${DISTDIR} and then run make again.
.endif
.endfor