aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
Diffstat (limited to 'java')
-rw-r--r--java/openjdk6/Makefile4
-rw-r--r--java/openjdk6/distinfo4
-rw-r--r--java/openjdk6/files/patch-set38
3 files changed, 30 insertions, 16 deletions
diff --git a/java/openjdk6/Makefile b/java/openjdk6/Makefile
index be132151e0cb..768133682e26 100644
--- a/java/openjdk6/Makefile
+++ b/java/openjdk6/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openjdk6
-PORTVERSION= b38
+PORTVERSION= b39
PORTEPOCH= 1
CATEGORIES= java devel
MASTER_SITES= APACHE/ant/binaries/:ant \
@@ -27,7 +27,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2
RUN_DEPENDS= javavm:java/javavmwrapper \
dejavu>0:x11-fonts/dejavu
-OPENJDK_BUILDDATE= 20_jan_2016
+OPENJDK_BUILDDATE= 03_may_2016
OPTIONS_DEFINE= ICEDTEA IPV6 POLICY SOUND TZUPDATE
OPTIONS_DEFAULT=ICEDTEA IPV6 TZUPDATE
diff --git a/java/openjdk6/distinfo b/java/openjdk6/distinfo
index f551acadfac7..841837c4eeac 100644
--- a/java/openjdk6/distinfo
+++ b/java/openjdk6/distinfo
@@ -1,6 +1,6 @@
SHA256 (apache-ant-1.9.6-bin.tar.bz2) = a43b0928960d63d6b1e2bed37e1ce4fd8fa1788ba84e08388bfe9513f02e8db3
SIZE (apache-ant-1.9.6-bin.tar.bz2) = 4385004
-SHA256 (openjdk-6-src-b38-20_jan_2016.tar.xz) = ff88dbcbda6c3c7d80b7cbd28065a455cdb009de9874fcf9ff9ca8205d38a257
-SIZE (openjdk-6-src-b38-20_jan_2016.tar.xz) = 33845368
+SHA256 (openjdk-6-src-b39-03_may_2016.tar.xz) = d11dc2ababe88e7891f1abbd7fa4fe033a65dea22c071331a641374b3247717f
+SIZE (openjdk-6-src-b39-03_may_2016.tar.xz) = 33887004
SHA256 (jtreg-4.1-bin-b05_29_nov_2012.zip) = 9291eb4a14501232b35614e88686ff66ad8b69d0098dbd4322b28f97b672653d
SIZE (jtreg-4.1-bin-b05_29_nov_2012.zip) = 5993382
diff --git a/java/openjdk6/files/patch-set b/java/openjdk6/files/patch-set
index 63171e9eef01..cf2f76bd1eca 100644
--- a/java/openjdk6/files/patch-set
+++ b/java/openjdk6/files/patch-set
@@ -2826,7 +2826,7 @@
// the installation of the klass pointer into the new klass "k"
--- hotspot/src/share/vm/oops/klass.hpp
+++ hotspot/src/share/vm/oops/klass.hpp
-@@ -167,7 +167,7 @@
+@@ -168,7 +168,7 @@
bool null_vtbl() { return *(intptr_t*)this == 0; }
protected:
@@ -2835,6 +2835,20 @@
};
+@@ -419,11 +419,11 @@
+ }
+ static bool layout_helper_is_typeArray(jint lh) {
+ // _lh_array_tag_type_value == (lh >> _lh_array_tag_shift);
+- return (juint)lh >= (juint)(_lh_array_tag_type_value << _lh_array_tag_shift);
++ return (juint)lh >= (juint)((juint)_lh_array_tag_type_value << _lh_array_tag_shift);
+ }
+ static bool layout_helper_is_objArray(jint lh) {
+ // _lh_array_tag_obj_value == (lh >> _lh_array_tag_shift);
+- return (jint)lh < (jint)(_lh_array_tag_type_value << _lh_array_tag_shift);
++ return (jint)lh < (jint)((juint)_lh_array_tag_type_value << _lh_array_tag_shift);
+ }
+ static int layout_helper_header_size(jint lh) {
+ assert(lh < (jint)_lh_neutral_value, "must be array");
--- hotspot/src/share/vm/oops/symbol.cpp
+++ hotspot/src/share/vm/oops/symbol.cpp
@@ -36,7 +36,7 @@
@@ -2948,15 +2962,6 @@
Node* n = (Node*)C->node_arena()->Amalloc_D(x);
#ifdef ASSERT
n->_in = (Node**)n; // magic cookie for assertion check
-@@ -218,7 +218,7 @@
-
- // New Operator that takes a Compile pointer, this will eventually
- // be the "new" New operator.
-- inline void* operator new( size_t x, Compile* C, int y) {
-+ inline void* operator new( size_t x, Compile* C, int y) throw() {
- Node* n = (Node*)C->node_arena()->Amalloc_D(x + y*sizeof(void*));
- n->_in = (Node**)(((char*)n) + x);
- #ifdef ASSERT
--- hotspot/src/share/vm/opto/parse3.cpp
+++ hotspot/src/share/vm/opto/parse3.cpp
@@ -487,7 +487,8 @@
@@ -9031,7 +9036,7 @@
* Function prototypes.
--- jdk/src/solaris/classes/sun/awt/X11GraphicsEnvironment.java
+++ jdk/src/solaris/classes/sun/awt/X11GraphicsEnvironment.java
-@@ -403,7 +403,7 @@
+@@ -413,7 +413,7 @@
if (fontID != null) {
fileName = (String)fontNameMap.get(fontID);
/* On Linux check for the Lucida Oblique fonts */
@@ -9040,7 +9045,7 @@
if (oblmap == null) {
initObliqueLucidaFontMap();
}
-@@ -639,7 +639,7 @@
+@@ -649,7 +649,7 @@
if (fontConfigDirs == null) {
return;
}
@@ -9049,6 +9054,15 @@
fontConfigDirs.add(jreLibDirName+File.separator+"oblique-fonts");
}
fontdirs = (String[])fontConfigDirs.toArray(new String[0]);
+@@ -930,7 +930,7 @@
+ */
+ FontConfiguration mFontConfig = new MFontConfiguration(this);
+ if (isOpenSolaris ||
+- (isLinux &&
++ (isLinuxOrBSD &&
+ (!mFontConfig.foundOsSpecificFile() ||
+ !mFontConfig.fontFilesArePresent()) ||
+ (isSolaris && !mFontConfig.fontFilesArePresent()))) {
--- jdk/src/solaris/classes/sun/nio/ch/DefaultSelectorProvider.java
+++ jdk/src/solaris/classes/sun/nio/ch/DefaultSelectorProvider.java
@@ -47,6 +47,10 @@