aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
Diffstat (limited to 'java')
-rw-r--r--java/linux-sun-jdk12/Makefile1
-rw-r--r--java/linux-sun-jdk13/Makefile1
-rw-r--r--java/linux-sun-jdk14/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/java/linux-sun-jdk12/Makefile b/java/linux-sun-jdk12/Makefile
index de3617b961c0..3dd1e4d89bf1 100644
--- a/java/linux-sun-jdk12/Makefile
+++ b/java/linux-sun-jdk12/Makefile
@@ -15,6 +15,7 @@ DISTNAME= ${PORTNAME}-${JDK_VERSION:S/./_/g}-linux-i586
MAINTAINER= znerd@FreeBSD.org
COMMENT= Sun Java Development Kit 1.2 for Linux
+EXTRACT_DEPENDS= ${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
BUILD_DEPENDS= ${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
RUN_DEPENDS= ${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
diff --git a/java/linux-sun-jdk13/Makefile b/java/linux-sun-jdk13/Makefile
index 43bc82e332a2..f3844c35e97e 100644
--- a/java/linux-sun-jdk13/Makefile
+++ b/java/linux-sun-jdk13/Makefile
@@ -17,6 +17,7 @@ EXTRACT_SUFX= .bin
MAINTAINER= znerd@FreeBSD.org
COMMENT= Sun Java Development Kit 1.3 for Linux
+EXTRACT_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
BUILD_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
diff --git a/java/linux-sun-jdk14/Makefile b/java/linux-sun-jdk14/Makefile
index 0422696064c2..c361ded0082d 100644
--- a/java/linux-sun-jdk14/Makefile
+++ b/java/linux-sun-jdk14/Makefile
@@ -17,6 +17,7 @@ EXTRACT_SUFX= .bin
MAINTAINER= znerd@FreeBSD.org
COMMENT= Sun Java Development Kit 1.4 for Linux
+EXTRACT_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
BUILD_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper