aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-sysdeo-tomcat/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/java/eclipse-sysdeo-tomcat/Makefile b/java/eclipse-sysdeo-tomcat/Makefile
index 90e6aa71ff97..1004c60b773e 100644
--- a/java/eclipse-sysdeo-tomcat/Makefile
+++ b/java/eclipse-sysdeo-tomcat/Makefile
@@ -20,13 +20,12 @@ USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-NO_STAGE= yes
do-install:
- @${MKDIR} -p ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/com.sysdeo.eclipse.tomcat_${PORTVERSION} ${PREFIX}/lib/eclipse/plugins
- @(cd ${WRKSRC}; ${FIND} -s com.sysdeo.eclipse.tomcat_${PORTVERSION} -not -type d) \
- | ${SED} -ne 's,^,lib/eclipse/plugins/,p' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d com.sysdeo.eclipse.tomcat_${PORTVERSION} -type d) \
- | ${SED} -ne 's,^,@dirrm lib/eclipse/plugins/,p' >> ${TMPPLIST}
+ @${MKDIR} -p ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/com.sysdeo.eclipse.tomcat_${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/eclipse/plugins
+ @(cd ${WRKSRC}; ${FIND} -s com.sysdeo.eclipse.tomcat_${PORTVERSION} -not -type d) \
+ | ${SED} -ne 's,^,lib/eclipse/plugins/,p' >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d com.sysdeo.eclipse.tomcat_${PORTVERSION} -type d) \
+ | ${SED} -ne 's,^,@dirrm lib/eclipse/plugins/,p' >> ${TMPPLIST}
.include <bsd.port.mk>