aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
Diffstat (limited to 'java')
-rw-r--r--java/openjdk8/Makefile4
-rw-r--r--java/openjdk8/files/fontconfig.patch17
2 files changed, 9 insertions, 12 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index 944a87b0ef8b..6421cbffb776 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -111,6 +111,7 @@ X11_MAKE_ENV_OFF= BUILD_HEADLESS_ONLY=1 \
MAKEFLAGS=X_CFLAGS="-I${LOCALBASE}/include"
X11_MAKE_ENV_ON= MAKEFLAGS=""
X11_USE= XORG=x11,xext,xi,xrender,xt,xtst
+FONTCONFIG_EXTRA_PATCHES= ${PATCHDIR}/fontconfig.patch
FONTCONFIG_IMPLIES= X11
JAVAVMS_COMMENT= OpenJDK${JDK_MAJOR_VERSION}
@@ -223,9 +224,6 @@ ICONV_LDFLAGS= -L${LOCALBASE}/lib ${ICONV_LIB}
post-extract-TEST-on:
@${LN} -sf ${WRKDIR}/jtreg/linux/bin ${WRKDIR}/jtreg/
-do-patch-FONTCONFIG-on:
- @${PATCH} -d ${PATCH_WRKSRC} < ${PATCHDIR}/fontconfig.patch
-
post-patch:
@${FIND} ${WRKSRC} -name '*.orig' -delete
@${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
diff --git a/java/openjdk8/files/fontconfig.patch b/java/openjdk8/files/fontconfig.patch
index f304824d71e2..925eeb4714c8 100644
--- a/java/openjdk8/files/fontconfig.patch
+++ b/java/openjdk8/files/fontconfig.patch
@@ -142,15 +142,17 @@
/*
* Class: sun_font_FreetypeFontScaler
-@@ -726,32 +850,15 @@ Java_sun_font_FreetypeFontScaler_getGlyp
+@@ -698,31 +826,15 @@
return ptr_to_jlong(getNullGlyphImage());
}
-- /* if algorithmic styling is required then we do not request bitmap */
-- if (context->doBold || context->doItalize) {
-- renderFlags = FT_LOAD_DEFAULT;
+- if (!context->useSbits) {
+- renderFlags |= FT_LOAD_NO_BITMAP;
- }
--
++ RenderingProperties renderingProperties;
++ readFontconfig((const FcChar8 *) scalerInfo->face->family_name,
++ context->ptsz, context->aaType, &renderingProperties);
+
- /* NB: in case of non identity transform
- we might also prefer to disable transform before hinting,
- and apply it explicitly after hinting is performed.
@@ -168,10 +170,7 @@
- target = FT_LOAD_TARGET_LCD_V;
- }
- renderFlags |= target;
-+ RenderingProperties renderingProperties;
-+ readFontconfig((const FcChar8 *) scalerInfo->face->family_name,
-+ context->ptsz, context->aaType, &renderingProperties);
-
+-
glyph_index = FT_Get_Char_Index(scalerInfo->face, glyphCode);
- error = FT_Load_Glyph(scalerInfo->face, glyphCode, renderFlags);