aboutsummaryrefslogtreecommitdiffstats
path: root/lang/afnix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/afnix/Makefile')
-rw-r--r--lang/afnix/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index 4f8b067a0094..80c6bf2d64f8 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -7,12 +7,12 @@
#
PORTNAME= afnix
-PORTVERSION= 1.5.0
+PORTVERSION= 1.5.1
CATEGORIES= lang
MASTER_SITES= http://www.afnix.org/ftp/%SUBDIR%/ \
ftp://ftp.stack.nl/pub/users/johans/afnix/
-MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION:S,.,-,g}
-DISTNAME= ${PORTNAME}-src-${PORTVERSION:S,.,-,g}
+MASTER_SITE_SUBDIR= ${PORTNAME}-${AFNIX_VERSION}
+DISTNAME= ${PORTNAME}-src-${AFNIX_VERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= johans@stack.nl
@@ -27,6 +27,7 @@ MAKE_ENV= CXX="${CXX}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PORTDOCS= *
+AFNIX_VERSION= ${PORTVERSION:S,.,-,g}
PLIST_SUB= PORTVER=${PORTVERSION:R}
MAN1= adp::afnix.1 amd::afnix.1 axc::afnix.1 axd::afnix.1 \
@@ -50,16 +51,13 @@ post-patch:
@${REINPLACE_CMD} -e '/uname -r/s/\\\./[.-]/' \
${WRKSRC}/cnf/bin/afnix-guess
+post-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} doc
+
post-install:
.ifdef NOPORTDOCS
-# install all manuals, but no other documentation
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} doc
-. for i in prj/amd/doc prj/adp/doc src/mod/xml src/srv/xpe
- @cd ${WRKSRC}/${i} && ${SETENV} ${MAKE_ENV} ${GMAKE} doc
-. endfor
. for i in ${MAN1} ${MAN3} ${MAN4} ${MAN7}
- ${INSTALL_MAN} \
- ${WRKSRC}/bld/${PORTNAME}-doc-${PORTVERSION:S,.,-,g}/man/$i \
+ ${INSTALL_MAN} ${WRKSRC}/bld/${PORTNAME}-doc-${AFNIX_VERSION}/man/$i \
${MANPREFIX}/man/man${i:E}/
. endfor
.else