aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/cel/Makefile')
-rw-r--r--lang/cel/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/lang/cel/Makefile b/lang/cel/Makefile
new file mode 100644
index 000000000000..12119e1a5253
--- /dev/null
+++ b/lang/cel/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cel
+# Date created: 1 January 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cel
+PORTVERSION= 0.5
+CATEGORIES= lang
+MASTER_SITES= http://www.redwoodsoft.com/cel/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+
+DOCFILES= CoreArchitecture.html Credits DefaultProtos \
+ Linker.html Logs.html ProtoLanguage.html README \
+ SimpleDataFormat.html Threads activation.html \
+ stackframe structure.html todo.html
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/vm/aq ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/cel
+.for F in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/doc/$F ${PREFIX}/share/doc/cel
+.endfor
+.endif
+
+.include <bsd.port.mk>