aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cel
diff options
context:
space:
mode:
Diffstat (limited to 'lang/cel')
-rw-r--r--lang/cel/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/cel/Makefile b/lang/cel/Makefile
index 12cb80517cd5..bf6dd0c43f9e 100644
--- a/lang/cel/Makefile
+++ b/lang/cel/Makefile
@@ -18,6 +18,7 @@ COMMENT= A small, simple prototype-based OO language
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
+USE_REINPLACE= yes
PORTDOCS= CoreArchitecture.html DefaultProtos Linker.html \
Logs.html ProtoLanguage.html README SimpleDataFormat.html \
@@ -26,6 +27,11 @@ PLIST_FILES= bin/cel
.include <bsd.port.pre.mk>
+post-patch:
+ ${REINPLACE_CMD} -e "s,-fno-omit-frame-pointer,${CFLAGS}," \
+ ${WRKSRC}/hash/Makefile ${WRKSRC}/kits/Makefile.unix \
+ ${WRKSRC}/vm/Makefile.unix
+
do-configure:
@cd ${WRKSRC}; ${SH} ./config.unix