aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cu-prolog
diff options
context:
space:
mode:
Diffstat (limited to 'lang/cu-prolog')
-rw-r--r--lang/cu-prolog/Makefile41
-rw-r--r--lang/cu-prolog/distinfo4
-rw-r--r--lang/cu-prolog/files/patch-aa16
-rw-r--r--lang/cu-prolog/files/patch-ab28
-rw-r--r--lang/cu-prolog/files/patch-ac14
-rw-r--r--lang/cu-prolog/files/patch-ad13
-rw-r--r--lang/cu-prolog/files/patch-ae21
-rw-r--r--lang/cu-prolog/files/patch-syspred1.c32
-rw-r--r--lang/cu-prolog/pkg-descr11
-rw-r--r--lang/cu-prolog/pkg-plist10
10 files changed, 0 insertions, 190 deletions
diff --git a/lang/cu-prolog/Makefile b/lang/cu-prolog/Makefile
deleted file mode 100644
index b004e0980958..000000000000
--- a/lang/cu-prolog/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# New ports collection makefile for: cu-Prolog
-# Date created: 7 July 1999
-# Whom: Issei Suzuki <issei@jp.FreeBSD.ORG>
-#
-# $FreeBSD$
-#
-
-PORTNAME= cu-prolog
-PORTVERSION= 3.94
-CATEGORIES= lang
-MASTER_SITES= ftp://ftp.icot.or.jp/ifs/kbms-clp/unix/cuprolog/ \
- http://mbsd.msk.ru/dist/
-DISTNAME= cupsrc
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} cupdoc${EXTRACT_SUFX}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Experimental constraint logic programming language
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-10-20
-
-WRKSRC= ${WRKDIR}/src
-MAKEFILE= makefile
-ALL_TARGET= cup
-PORTDOCS= *
-MYPORTDOCS= CHANGES COPYRIGHT COPYRIGHT.j INSTALL INSTALL.j README \
- README.j doc/cu3eman.dvi doc/cu3man.dvi doc/newpred_e.doc \
- doc/newpred_j.doc
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cup3 ${PREFIX}/bin/cuprolog
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKDIR}/sample/* ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${MYPORTDOCS}
- ${INSTALL_DATA} ${WRKDIR}/$i ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/lang/cu-prolog/distinfo b/lang/cu-prolog/distinfo
deleted file mode 100644
index 3535b2a8f7eb..000000000000
--- a/lang/cu-prolog/distinfo
+++ /dev/null
@@ -1,4 +0,0 @@
-SHA256 (cupsrc.tar.gz) = 5110723a4b93d1e103cf3a71da6ca3c56ee0da3f5bb0a7f74ba66861dbd85587
-SIZE (cupsrc.tar.gz) = 211847
-SHA256 (cupdoc.tar.gz) = 5e7d1287f1b06e5e4f168012dc03e9604a562495198e0c167ce832f5ed3c3302
-SIZE (cupdoc.tar.gz) = 136474
diff --git a/lang/cu-prolog/files/patch-aa b/lang/cu-prolog/files/patch-aa
deleted file mode 100644
index 71217e1d4125..000000000000
--- a/lang/cu-prolog/files/patch-aa
+++ /dev/null
@@ -1,16 +0,0 @@
---- makefile.old Wed Jul 7 02:03:58 1999
-+++ makefile Wed Jul 7 02:04:19 1999
-@@ -6,11 +6,11 @@
- refute.o unify.o defsysp.o syspred1.o\
- syspred2.o trans.o tr_sub.o tr_split.o
- #CFLAGS = -g
--CFLAGS = -pg -g # for debug
-+CFLAGS?= -pg -g # for debug
- #CFLAGS = -O2 # for optimization
- #CFLAGS = -O4
- #CC = gcc
--CC = cc
-+CC?= cc
- FLAGS = -lm
-
- cup: $(OBJECTS)
diff --git a/lang/cu-prolog/files/patch-ab b/lang/cu-prolog/files/patch-ab
deleted file mode 100644
index 4508cb32b44d..000000000000
--- a/lang/cu-prolog/files/patch-ab
+++ /dev/null
@@ -1,28 +0,0 @@
---- include.h.orig Fri Jan 27 16:38:48 1995
-+++ include.h Wed Jul 7 02:25:14 1999
-@@ -28,7 +28,11 @@
- * else #define CPUTIME 0
- */
-
-+#ifdef __FreeBSD__
-+#define CPUTIME 60
-+#else
- #define SUN4 1
-+#endif
- #define KANJI 1 /* 1: allow EUC Kanji for str functions */
-
- /* Tee print macro */
-@@ -135,8 +139,13 @@
- #define head_of_list(Term) (((struct clause *)Term)->c_form)
- #define tail_of_list(Term) ((struct term *)((struct clause *)Term)->c_link)
-
-+#ifdef __FreeBSD__
-+#define is_readable(FP) (FP->_flags & __SRD)
-+#define is_writable(FP) (FP->_flags & __SWR)
-+#else
- #define is_readable(FP) (FP->_flag & _IOREAD)
- #define is_writable(FP) (FP->_flag & _IOWRT)
-+#endif
-
- #define is_functor(Term) ((Term)->type.ident > CONST_LIST_TYPE)
- #define isconst_functor(Term) ((Term)->t_arity <= 0)
diff --git a/lang/cu-prolog/files/patch-ac b/lang/cu-prolog/files/patch-ac
deleted file mode 100644
index d2fb8d0e0d17..000000000000
--- a/lang/cu-prolog/files/patch-ac
+++ /dev/null
@@ -1,14 +0,0 @@
---- defsysp.c.old Wed Jul 7 02:21:11 1999
-+++ defsysp.c Wed Jul 7 02:21:32 1999
-@@ -932,9 +932,9 @@
- t1 = t2 = Nnum_val(0.0,TEMPORAL);
- #else
- times(&TIMES);
-- t1 = Nnum_val(((float)(TIMES.tms_stime+TIMES.tms_utime-OLD_TIME))/CPUTIME.0,
-+ t1 = Nnum_val(((float)(TIMES.tms_stime+TIMES.tms_utime-OLD_TIME))/(float)CPUTIME,
- TEMPORAL);
-- t2 = Nnum_val(((float)CONSTRAINT_HANDLING_TIME)/CPUTIME.0,TEMPORAL);
-+ t2 = Nnum_val(((float)CONSTRAINT_HANDLING_TIME)/(float)CPUTIME,TEMPORAL);
- #endif
- #endif
- upush(&(p1->p_body)); upush(&(p1->p_env));
diff --git a/lang/cu-prolog/files/patch-ad b/lang/cu-prolog/files/patch-ad
deleted file mode 100644
index c3e7d500cf95..000000000000
--- a/lang/cu-prolog/files/patch-ad
+++ /dev/null
@@ -1,13 +0,0 @@
---- mainsub.c.old Wed Jul 7 02:22:15 1999
-+++ mainsub.c Wed Jul 7 02:22:30 1999
-@@ -1238,8 +1238,8 @@
- times(&TIMES); /* get time */
- ttemp = TIMES.tms_stime + TIMES.tms_utime;
- tprint2 ("CPU time = %.3lf sec (Constraints Handling = %.3lf sec)\n",
-- (ttemp - TIMESAVE) / CPUTIME.0,
-- (CONSTRAINT_HANDLING_TIME / CPUTIME.0));
-+ (ttemp - TIMESAVE) / (float)CPUTIME,
-+ (CONSTRAINT_HANDLING_TIME / (float)CPUTIME));
- }
-
- void settimer() { /* set clock */
diff --git a/lang/cu-prolog/files/patch-ae b/lang/cu-prolog/files/patch-ae
deleted file mode 100644
index 92d9238faa23..000000000000
--- a/lang/cu-prolog/files/patch-ae
+++ /dev/null
@@ -1,21 +0,0 @@
---- main.c.old Wed Jul 7 02:26:00 1999
-+++ main.c Wed Jul 7 02:27:38 1999
-@@ -303,13 +303,16 @@
-
- void heap_realloc() /* reallocate system/user heaps */
- {
-+#if SUN4 == 1
- cfree((char *)sheap); SHEAP_SIZE=SHEAP_SIZE*1.2; system_heap_alloc();
--/* free(heap); HEAP_SIZE *= 1.2;
-+#else
-+ free(heap); HEAP_SIZE *= 1.2;
- free(cheap); CHEAP_SIZE *= 1.2;
- free(eheap); ESP_SIZE *= 1.2;
- free(ustack); USTACK_SIZE *= 1.2;
- free(nheap); NAME_SIZE *= 1.2;
-- heap_alloc(); */
-+ heap_alloc();
-+#endif /* SUN4 */
- init_status();
- }
-
diff --git a/lang/cu-prolog/files/patch-syspred1.c b/lang/cu-prolog/files/patch-syspred1.c
deleted file mode 100644
index 52379121573e..000000000000
--- a/lang/cu-prolog/files/patch-syspred1.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- syspred1.c.orig Thu Dec 14 22:30:29 2006
-+++ syspred1.c Thu Dec 14 22:35:14 2006
-@@ -1094,6 +1094,7 @@
- struct clause *root;
- register struct term *tt, *temp;
- int pos = 0, arity;
-+ struct term *tt1;
-
- if (is_atomic(t)) return((struct clause *)NIL);
- if ((arity = t->t_arity)==0) return((struct clause *)NIL);
-@@ -1105,8 +1106,9 @@
- head_of_list(tt) = Arg(t,pos);
- pos++;
- if (pos >= arity) break;
-- tail_of_list(tt) = temp =
-- (struct term *)Nlist(NIL,(struct clause *)NIL,TEMPORAL);
-+ tt1 = tail_of_list(tt);
-+ temp = (struct term *)Nlist(NIL,(struct clause *)NIL,TEMPORAL);
-+ tt1 = (struct term *)Nlist(NIL,(struct clause *)NIL,TEMPORAL);
- tt = temp;
- }
- return(root);
-@@ -1227,8 +1229,7 @@
- head_of_list(t) = Nstr(s, TEMPORAL);
- }
- if (nbuf[pos] == '\0') return(root);
-- t = (tail_of_list(t) =
-- (struct term *)Nlist(NIL,(struct clause *)NIL,TEMPORAL));
-+ t = (struct term *)Nlist(NIL,(struct clause *)NIL,TEMPORAL);
- }
- }
-
diff --git a/lang/cu-prolog/pkg-descr b/lang/cu-prolog/pkg-descr
deleted file mode 100644
index cb5a75a3bc37..000000000000
--- a/lang/cu-prolog/pkg-descr
+++ /dev/null
@@ -1,11 +0,0 @@
-cu-Prolog is an experimental constraint logic programming language.
-Unlike most conventional CLP systems, cu-Prolog allows user-defined
-predicates as constraints and is suitable for implementing a natural
-language processing system based on the unification-based
-grammar. As an application of cu-Prolog, we developed
-a JPSG (Japanese Phrase Structure Grammar) parser
-with the JPSG Working Group (the chairman is Prof. GUNJI, Takao of
-Osaka University) at ICOT.
-
-cu-Prolog is also the complete implementation of the constraint
-unification and its name (cu) comes from the technique.
diff --git a/lang/cu-prolog/pkg-plist b/lang/cu-prolog/pkg-plist
deleted file mode 100644
index 4e1983160e45..000000000000
--- a/lang/cu-prolog/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-bin/cuprolog
-%%EXAMPLESDIR%%/README
-%%EXAMPLESDIR%%/bagof.p
-%%EXAMPLESDIR%%/eisele.p
-%%EXAMPLESDIR%%/hpsg.p
-%%EXAMPLESDIR%%/jpsg.p
-%%EXAMPLESDIR%%/kasper.p
-%%EXAMPLESDIR%%/marcus.p
-%%EXAMPLESDIR%%/memap.p
-@dirrm %%EXAMPLESDIR%%