aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cyclone
diff options
context:
space:
mode:
Diffstat (limited to 'lang/cyclone')
-rw-r--r--lang/cyclone/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/cyclone/Makefile b/lang/cyclone/Makefile
index 2ee65c8db935..084ea5f33019 100644
--- a/lang/cyclone/Makefile
+++ b/lang/cyclone/Makefile
@@ -20,6 +20,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
MAINTAINER= ports@FreeBSD.org
COMMENT= A safe dialect of C from Cornell and AT&T Research
+USE_REINPLACE= yes
USE_GMAKE= yes
NO_PACKAGE= 'Neither CC nor CFLAGS safe.'
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -36,7 +37,7 @@ pre-everything::
post-patch:
.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
's/-O3/-O/'
.endif