aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/erlang/Makefile')
-rw-r--r--lang/erlang/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 8ebd561cbc7f..2cd1d816d5f3 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= erlang
-PORTVERSION= 16.b.03.1
+PORTVERSION= 17.1
PORTEPOCH= 3
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
@@ -42,19 +42,19 @@ SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
GS_DESC= Enable GS application (deprecated)
-DTRACE_DESC= Enable DTrace support (experimental)
+DTRACE_DESC= Enable DTrace support
OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
-ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
+ERL_RELEASE= ${PORTVERSION}
USES= gmake perl5
USE_RC_SUBR= epmd
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
-EI_VSN= 3.7.15
-TOOLS_VSN= 2.6.13
+EI_VSN= 3.7.17
+TOOLS_VSN= 2.6.15
.include <bsd.port.options.mk>
@@ -77,9 +77,11 @@ DOC_DISTFILES= armstrong_thesis_2003.pdf:joe \
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
+.if ${OSVERSION} < 1000000
.if ${ARCH} == "amd64" && ${PORT_OPTIONS:MDTRACE} && ! ${PORT_OPTIONS:MGCC}
IGNORE= DTRACE support on amd64 requires GCC option
.endif
+.endif
.if ${PORT_OPTIONS:MGCC}
USE_GCC?= yes
@@ -178,7 +180,6 @@ MAKE_ARGS+= ARCH=x86
post-patch:
@${ECHO_CMD} "MANPATH ${PREFIX}/lib/erlang/man" > ${WRKDIR}/erlang.conf
-
post-install:
${INSTALL_DATA} ${WRKDIR}/erlang.conf ${STAGEDIR}${PREFIX}/etc/man.d/erlang.conf
${LN} -sf ../lib/${ERLANG_LIB}/lib/erl_interface-${EI_VSN}/bin/erl_call ${STAGEDIR}${PREFIX}/bin/erl_call