aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang14
diff options
context:
space:
mode:
Diffstat (limited to 'lang/erlang14')
-rw-r--r--lang/erlang14/Makefile8
-rw-r--r--lang/erlang14/files/patch-erts_etc_common_Install11
2 files changed, 18 insertions, 1 deletions
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 0530f36a3a82..80b315a4b123 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -141,11 +141,17 @@ post-install:
# All non-library files.
+ @cd ${PREFIX} ; ${FIND} lib/erlang/* -type d -empty \
+ | ${GREP} -v "^lib/erlang/lib" \
+ | ${SORT} \
+ | ${SED} -e 's#^#@exec ${MKDIR} %D/#g' \
+ > ${ERLANG_PLIST}
+
@cd ${PREFIX} ; ${FIND} lib/erlang/* -type f -o -type l \
| ${GREP} -v "^lib/erlang/man" \
| ${GREP} -v "^lib/erlang/lib" \
| ${SORT} \
- > ${ERLANG_PLIST}
+ >> ${ERLANG_PLIST}
# Stock OTP libraries.
diff --git a/lang/erlang14/files/patch-erts_etc_common_Install b/lang/erlang14/files/patch-erts_etc_common_Install
new file mode 100644
index 000000000000..837769cfa6b7
--- /dev/null
+++ b/lang/erlang14/files/patch-erts_etc_common_Install
@@ -0,0 +1,11 @@
+
+$FreeBSD$
+
+--- erts/etc/common/Install.orig
++++ erts/etc/common/Install
+@@ -148,4 +148,4 @@
+ ./misc/format_man_pages $ERL_ROOT
+ fi
+
+-
++exit 0