aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ezm3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ezm3/Makefile')
-rw-r--r--lang/ezm3/Makefile41
1 files changed, 34 insertions, 7 deletions
diff --git a/lang/ezm3/Makefile b/lang/ezm3/Makefile
index cd98d0a3e162..3495c08fafa3 100644
--- a/lang/ezm3/Makefile
+++ b/lang/ezm3/Makefile
@@ -8,10 +8,20 @@
PORTNAME= ezm3
PORTVERSION= 1.2
CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_FREEBSD_ORG}
-MASTER_SITE_SUBDIR=development/CVSup/ezm3
-DISTFILES= ezm3-${PORTVERSION}-${TARGET}-boot.tar.bz2 \
- ezm3-${PORTVERSION}-src.tar.bz2
+
+MASTER_SITES= ftp://ftp.FreeBSD.org/pub/FreeBSD/development/CVSup/ezm3/:src \
+ http://people.freebsd.org/~peter/ezm3-amd64/:amdb \
+ ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/pav/:amdp
+DISTFILES= ezm3-${PORTVERSION}-src.tar.bz2:src
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+DISTFILES+= ezm3-${PORTVERSION}-${TARGET}-boot.tar.bz2:amdb \
+ ezm3-amd64-patchset.tar.bz2:amdp
+.else
+DISTFILES+= ezm3-${PORTVERSION}-${TARGET}-boot.tar.bz2:src
+.endif
MAINTAINER= jdp@FreeBSD.org
COMMENT= Easier, more portable Modula-3 distribution for building CVSup
@@ -32,9 +42,7 @@ PROGS= bin/m3build \
bin/m3ship \
lib/m3/${TARGET}/m3cgc1
-.include <bsd.port.pre.mk>
-
-ONLY_FOR_ARCHS= alpha i386 sparc64
+ONLY_FOR_ARCHS= alpha amd64 i386 sparc64
.if ${OSVERSION} < 410000
BROKEN= Not supported on versions earlier than 4.1-RELEASE
@@ -44,14 +52,26 @@ BROKEN= Not supported on versions earlier than 4.1-RELEASE
TARGET= FBSD_ALPHA
WORDSIZE= 64
ENDIANESS= le
+PLIST_SUB+= AMD64="@comment "
+.elif ${ARCH} == "amd64"
+MAINTAINER= bzeeb+freebsdports@zabbadoz.net
+PORTVERSION= 1.1
+AMD64_PATCHES= p-amd64-common p-amd64-gcc p-amd64-gcc-321-322 p-amd64-gcchacks \
+ p-amd64-gccstatic p-amd64-m3 p-amd64-m3-except-sort p-amd64-newfiles
+TARGET= FBSD_AMD64
+WORDSIZE= 64
+ENDIANESS= le
+PLIST_SUB+= AMD64=""
.elif ${ARCH} == "i386"
TARGET= FreeBSD4
WORDSIZE= 32
ENDIANESS= le
+PLIST_SUB+= AMD64="@comment "
.elif ${ARCH} == "sparc64"
TARGET= FBSD_SPARC64
WORDSIZE= 64
ENDIANESS= be
+PLIST_SUB+= AMD64="@comment "
.endif
# The build fails for -O2 or greater. Override it with plain -O.
@@ -59,6 +79,13 @@ ENDIANESS= be
CFLAGS+= -O
.endif
+pre-patch:
+.if ${ARCH} == "amd64"
+.for f in ${AMD64_PATCHES}
+ @cd ${WRKSRC} && ${PATCH} ${PATCH_ARGS} < ${WRKDIR}/${f}
+.endfor
+.endif
+
post-patch:
.if ${ARCH} == "sparc64" && ${OSVERSION} < 502107
@${REINPLACE_CMD} -E -e 's|(^.*time_t.*=.*)int64_t;|\1int32_t;|' \