aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gambit-c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gambit-c/Makefile')
-rw-r--r--lang/gambit-c/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/lang/gambit-c/Makefile b/lang/gambit-c/Makefile
index 3c1f5248a97d..99dcfd3a4022 100644
--- a/lang/gambit-c/Makefile
+++ b/lang/gambit-c/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gambit-c
-DISTVERSION= v4_6_1
+DISTVERSION= v4_6_2
PORTEPOCH= 1
CATEGORIES= lang
MASTER_SITES= http://www.iro.umontreal.ca/~gambit/download/gambit/v4.6/source/
@@ -16,19 +16,27 @@ EXTRACT_SUFX= .tgz
MAINTAINER= pmn@bakarika.net
COMMENT= Gambit programming system where the compiler generates portable C code
+LICENSE= ASL
+
MAN1= gsi.1
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS = --enable-single-host --enable-gcc-opts
-CONFIGURE_ARGS+= --prefix=${PREFIX} --docdir=${PREFIX}/share/doc/gambit-c
-CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/gambit-c/ --includedir=${PREFIX}/include/gambit-c
-CONFIGURE_ARGS+= --enable-interpreter-name=gsi-gambit --enable-compiler-name=gsc-gambit
+CONFIGURE_ARGS =--enable-single-host --enable-gcc-opts
+CONFIGURE_ARGS+=--prefix=${PREFIX} --docdir=${PREFIX}/share/doc/gambit-c
+CONFIGURE_ARGS+=--libdir=${PREFIX}/lib/gambit-c/ --includedir=${PREFIX}/include/gambit-c
+CONFIGURE_ARGS+=--enable-interpreter-name=gsi-gambit --enable-compiler-name=gsc-gambit
-INFO= gambit-c
+INFO= gambit-c
MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= ${PREFIX}/lib/gambit-c
+
+PLIST_SUB+= GSI_INC=include/gambit-c
+PLIST_SUB+= GSI_DOC=share/doc/gambit-c
+PLIST_SUB+= GSI_LIB=lib/gambit-c
+
.include <bsd.port.pre.mk>
# This is needed because 4.2 < gcc -v < 4.4 has optimisations that make the