aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc/Makefile')
-rw-r--r--lang/gcc/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 7d7f789acf22..34c4bd92afa5 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.2.0
-PORTREVISION= 20060909
+PORTREVISION= 20060916
CATEGORIES= lang java
VERSIONSTRING= 4.2-${PORTREVISION}
MASTER_SITES= ${MASTER_SITE_GCC}
@@ -51,7 +51,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
CONFIGURE_ARGS+= --disable-libgomp
.endif
-.if ${ARCH} != i386
+.if ${ARCH} != i386 && ${ARCH} != amd64
WITHOUT_JAVA= yes
.endif
@@ -155,16 +155,9 @@ post-install:
for mp in ${_MANPAGES}; do \
${TEST} -e $${mp} || ${TOUCH} ${TOUCH_FLAGS} $${mp}; \
done
-.for f in c++ gcc g++ cpp gcov ${CONFIGURE_TARGET}-gcc ${CONFIGURE_TARGET}-g++ gcj gcjh gij jv-scan jcf-dump jv-convert jar grepjar rmic rmiregistry
- # gij and jv-convert, for example, are not built on all platforms.
- if [ -e ${PREFIX}/man/man1/${f}.1 ]; then \
- ${MV} -f ${PREFIX}/man/man1/${f}.1 \
- ${PREFIX}/man/man1/${f}${SUFFIX}.1; \
- fi
-.endfor
- ${RM} -f ${TARGLIB}/*.la
${RM} -f ${PREFIX}/man/man7/fsf-funding.7 \
${PREFIX}/man/man7/gfdl.7 ${PREFIX}/man/man7/gpl.7
+ ${RM} -f ${TARGLIB}/*.la
# Add target libraries and include files to packaging list.
${RM} -f ${WRKDIR}/PLIST.lib
.for d in ${TARGLIB:S/^${PREFIX}\///} libexec/gcc/${CONFIGURE_TARGET}/${PORTVERSION} include/gcj include/gnu include/java include/javax