aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc10-devel
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc10-devel')
-rw-r--r--lang/gcc10-devel/Makefile1
-rw-r--r--lang/gcc10-devel/files/patch-value-prof.c-buildfix4
2 files changed, 3 insertions, 2 deletions
diff --git a/lang/gcc10-devel/Makefile b/lang/gcc10-devel/Makefile
index 176940372a6d..8f855c1714e5 100644
--- a/lang/gcc10-devel/Makefile
+++ b/lang/gcc10-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gcc
PORTVERSION= 10.0.1.s20200223
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
diff --git a/lang/gcc10-devel/files/patch-value-prof.c-buildfix b/lang/gcc10-devel/files/patch-value-prof.c-buildfix
index b8d56288fcef..282cfaf11823 100644
--- a/lang/gcc10-devel/files/patch-value-prof.c-buildfix
+++ b/lang/gcc10-devel/files/patch-value-prof.c-buildfix
@@ -1,4 +1,4 @@
-This is a temporary hack of mine to unbreak the build; I'm working with
+This is a proposed fix of mine to unbreak the build; I'm working with
upstream. -- Gerald
--- UTC
@@ -9,7 +9,7 @@ upstream. -- Gerald
{
fprintf (dump_file, " all: %" PRId64 "%s, values: ",
- abs ((int64_t) hist->hvalue.counters[0]),
-+ ((int64_t) hist->hvalue.counters[0]),
++ std::abs ((int64_t) hist->hvalue.counters[0]),
hist->hvalue.counters[0] < 0
? " (values missing)": "");
for (unsigned i = 0; i < GCOV_TOPN_VALUES; i++)