aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc40/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc40/Makefile')
-rw-r--r--lang/gcc40/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/lang/gcc40/Makefile b/lang/gcc40/Makefile
index 62f77cf5bb44..b8364152fa39 100644
--- a/lang/gcc40/Makefile
+++ b/lang/gcc40/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.0.1
-PORTREVISION= 20050514
+PORTREVISION= 20050521
CATEGORIES= lang java
VERSIONSTRING= 4.0-${PORTREVISION}
MASTER_SITES= ${MASTER_SITE_GCC}
@@ -138,7 +138,12 @@ post-build:
check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
-post-install: fake-manpages
+post-install:
+ # man pages can only be generated if Perl >= 5.6 is installed;
+ # fake them otherwise.
+ for mp in ${_MANPAGES}; do \
+ ${TEST} -e $${mp} || ${TOUCH} ${TOUCH_FLAGS} $${mp}; \
+ done
.for f in c++ gcc g++ cpp gcov ${CONFIGURE_TARGET}-gcc ${CONFIGURE_TARGET}-g++ gcj gcjh gij jv-scan jcf-dump jv-convert jar grepjar rmic rmiregistry
# gij and jv-convert, for example, are not built on all platforms.
if [ -e ${PREFIX}/bin/${f}${SUFFIX} ]; then \
@@ -178,10 +183,3 @@ cklatest:
.endfor
.include <bsd.port.post.mk>
-
-fake-manpages:
- # man pages can only be generated if Perl >= 5.6 is installed, so
- # fake them on 4.x systems.
-.for mp in ${_MANPAGES}
- ( ${TEST} -e ${mp} || ${TOUCH} ${TOUCH_FLAGS} ${mp} )
-.endfor