aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc43/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc43/Makefile')
-rw-r--r--lang/gcc43/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index e1ce4c1d4dd2..7ce6aba9d790 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -7,10 +7,8 @@
#
PORTNAME= gcc
-PORTVERSION= 4.3.4
-PORTREVISION= 20090517
+PORTVERSION= 4.3.4.20090524
CATEGORIES= lang java
-VERSIONSTRING= 4.3-${PORTREVISION}
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
@@ -29,6 +27,7 @@ DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
+VERSIONSTRING= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\1-\2/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64 powerpc
@@ -71,7 +70,8 @@ CONFIGURE_ARGS+= --disable-nls \
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
-PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
+PLIST_SUB= GCC_VER=${PORTVERSION:C/(.+)\.[0-9]+/\1/} \
+ GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
g++${SUFFIX}.1 \
@@ -129,7 +129,7 @@ PLIST_SUB+= JAVA="@comment "
.endif
pre-everything::
- @${ECHO_MSG} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
+ @${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
.if ! defined(WITHOUT_JAVA)
@DSIZ=700000; DSIZBYTE=734003200; \
if [ `ulimit -d` -lt $$DSIZ ]; then \