aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gnustep-objc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gnustep-objc/Makefile')
-rw-r--r--lang/gnustep-objc/Makefile57
1 files changed, 10 insertions, 47 deletions
diff --git a/lang/gnustep-objc/Makefile b/lang/gnustep-objc/Makefile
index 468c693462d2..eeccf37dae34 100644
--- a/lang/gnustep-objc/Makefile
+++ b/lang/gnustep-objc/Makefile
@@ -1,55 +1,18 @@
-# New ports collection makefile for: gnustep-objc
-# Date created: 17 April 2001
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
+# New ports collection makefile for: gnustep-objc
+# Date created: 28.Mar.2003
+# Whom: dirk.meyer@dinoex.sub.org
#
# $FreeBSD$
#
-PORTNAME= gnustep-objc
-PORTVERSION= 1.2.2
-CATEGORIES= lang devel
-MASTER_SITES= ${MASTER_SITE_GNUSTEP} \
- ftp://ftp.gnustep.org/pub/gnustep/%SUBDIR%/
-MASTER_SITE_SUBDIR= libs
+MASTERDIR?= ${.CURDIR}/../../lang/gcc32
-MAINTAINER= dinoex@FreeBSD.org
-COMMENT= A snapshot of libobjc, meant to be used with GNUstep
+WANT_SHAREDLIBS= yes
+WANT_THREADS_SUPPORT= yes
+PKGNAMESUFFIX= -objc
-BUILD_DEPENDS= ${SYSTEMDIR}/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep-make \
- ${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall
-RUN_DEPENDS= ${SYSTEMDIR}/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep-make
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 300000
-BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
-.endif
-
-PREFIX= ${LOCALBASE}/GNUstep
-USE_GMAKE= yes
-MAKEFILE= GNUmakefile
-ALL_TARGET=
-NO_MTREE= yes
-INSTALLS_SHLIB= yes
-NOT_FOR_ARCHS= ia64
-IGNORE= "This port is obsolete with gnustep-1.5.2"
-
-.if ${MACHINE_ARCH} == "i386"
-GNU_ARCH= ix86
-.else
-GNU_ARCH= ${MACHINE_ARCH}
+.if exists(${.CURDIR}/Makefile.local)
+.include "${.CURDIR}/Makefile.local"
.endif
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION} \
- MAJORVERSION=${PORTVERSION:C/([0-9]).*/\1/1}
-
-SYSTEMDIR= ${LOCALBASE}/GNUstep/System
-
-do-build:
- (cd ${WRKSRC}; . ${SYSTEMDIR}/Makefiles/GNUstep.sh; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
-
-do-install:
- @(cd ${WRKSRC}; . ${SYSTEMDIR}/Makefiles/GNUstep.sh; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"